"could not be converged" error while performing convergence on vCenter server.
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"could not be converged" error while performing convergence on vCenter server.

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Article ID: 321969

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

Symptoms:

  • While initiating convergence from system configuration UI, the task fails immediately with error <VCSA-FQDN> could not be converged.
  • Under /var/log/vmware/converge/ directory, the converge.log does not get created.
  • You will not observe any logs related to convergence task failure in vsphere_client_virgo.log file location: /var/log/vmware/vsphere-ui/logs. The only log entry you see is:
[YYYY-MM-DDTHH:MM:SS] [INFO ] http-nio-5090-exec-1          c.vmware.vsphere.client.h5.admin.controllers.ConvergeController   POST /converge
  • You will see "<VC-FQDN> does not exist in user session" from browser's Network tab under Developer Tools.

 
 



Environment

VMware vCenter Server Appliance 6.7.x

Cause

This issue is caused due to the case mismatch of vCenter Server FQDN in LookupService and the FQDN used by vSphere Client network call.

Resolution

This is a know issue currently affecting vCenter Server Appliance 6.7. Currently there is no resolution.

Workaround:

Please follow one of the following option to workaround the issue.

Option a: 

Option b: 

  1. Run the following command to get VCSA FQDN as registered in LookupService. 
    • /usr/lib/vmidentity/tools/scripts/lstool.py list --url https://localhost/lookupservice/sdk --no-check-cert --type vcenterserver | grep -i https://<FQDN of VCSA to be convrged>:443/sdk
  2. Open VC in *Firefox browser* and navigate to System Configuration-UI
  3. On the Firefox browser application menu, launch "Web Developer Tools"

 

4. Right click on the convergence call in Network tab and click "Edit and resend".
5. Modify the FQDN of vCenter under "Query String" to match the case from output of 'step:1' and click Send.
6. This will trigger Convergence of vCenter but the progress of convergence wont be visible on UI. Instead, you will need to look at converge.log under /var/log/vmware/converge/ to monitor progress.
7. For a successful convergence you will see the following entries under
/var/log/vmware/converge/converge.log
YYYY-MM-DDTHH:MM:SS INFO converge Unsetting the converge running flag
YYYY-MM-DDTHH:MM:SS INFO converge Cleanup successful with partial flag = False.
YYYY-MM-DDTHH:MM:SS DEBUG converge Updating the DCUI console.
YYYY-MM-DDTHH:MM:SS INFO converge Converged the external PSC to embedded PSC Successfully.
YYYY-MM-DDTHH:MM:SS INFO converge Join AD domain if required.
YYYY-MM-DDTHH:MM:SS INFO converge Skipping AD Domain joining.
YYYY-MM-DDTHH:MM:SS INFO converge Collected end_time:1625045459.2373474 as a part of Telemetry
YYYY-MM-DDTHH:MM:SS INFO converge Collected status:True as a part of Telemetry
YYYY-MM-DDTHH:MM:SS INFO converge Collected @type:convergence_telemetry as a part of Telemetry
YYYY-MM-DDTHH:MM:SS DEBUG converge Starting new HTTP connection (1): localhost
YYYY-MM-DDTHH:MM:SS DEBUG converge http://localhost:15080 "POST /analytics/telemetry/ph/api/hyper/send?_c=vcebc.1_0 HTTP/1.1" 201 0
YYYY-MM-DDTHH:MM:SSDEBUG converge Pushed the Collected Data to VMWare Analytics Service as a part of Telemetry.