Update option values: A general system error occurred: Internal error message is repeatedly displayed in the vSphere Client UI
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Update option values: A general system error occurred: Internal error message is repeatedly displayed in the vSphere Client UI

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Article ID: 321874

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Updated On: 04-01-2025

Products

VMware vCenter Server VMware vSphere ESXi

Issue/Introduction

Symptoms:

Update option values: A general system error occurred: Internal error message is repeatedly displayed in the vSphere Client UI.

  • In the ESXi /var/run/log/hostd.log, you can find the following error message:
[YYYY-MM-DDTHH:MM:SS] info hostd[2099747] [Originator@6876 sub=AdapterServer opID=56476aec-8f-f2f5 user=vpxuser:VSPHERE.LOCAL\Administrator] AdapterServer caught exception; <<52441099-5b4d-da5c-3c61-ae90ea35c5e5, <TCP '127.0.0.1 : 8307'>, <TCP '127.0.0.1 : 11651'>>, ha-adv-options, vim.option.OptionManager.updateValues>, N5Vmomi5Fault11SystemError9ExceptionE(Fault cause: vmodl.fault.SystemError
--> )
--> [context]zKq7AVICAgAAANQIPgEPaG9zdGQAANJCF2xpYnZtYWNvcmUuc28AAYhiT2hvc3RkAAEq8lEBIluyAUKZsgEoSk8BzaSXAfeZl4JcCjABbGlidmltLXR5cGVzLnNvAAHallIAzMctAFQDLgACET8DO30AbGlicHRocmVhZC5zby4wAARt0Q5saWJjLnNvLjYA[/context]
[YYYY-MM-DDTHH:MM:SS] info hostd[2099747] [Originator@6876 sub=Vimsvc.TaskManager opID=56476aec-8f-f2f5 user=vpxuser:VSPHERE.LOCAL\Administrator] Task Completed : haTask-ha-host-vim.option.OptionManager.updateValues-13881790 Status error
[YYYY-MM-DDTHH:MM:SS] info hostd[2099747] [Originator@6876 sub=Solo.Vmomi opID=56476aec-8f-f2f5 user=vpxuser:VSPHERE.LOCAL\Administrator] Activation finished; <<52441099-5b4d-da5c-3c61-ae90ea35c5e5, <TCP '127.0.0.1 : 8307'>, <TCP '127.0.0.1 : 11651'>>, ha-adv-options, vim.option.OptionManager.updateValues>
[YYYY-MM-DDTHH:MM:SS] verbose hostd[2099747] [Originator@6876 sub=Solo.Vmomi opID=56476aec-8f-f2f5 user=vpxuser:VSPHERE.LOCAL\Administrator] Arg changedValue:
--> (vim.option.OptionValue) [
-->    (vim.option.OptionValue) {
-->       key = "Syslog.global.logHost",
-->       value = "udp://syslog_server_fqdn:514"
-->    }
--> ]
[YYYY-MM-DDTHH:MM:SS] info hostd[2099747] [Originator@6876 sub=Solo.Vmomi opID=56476aec-8f-f2f5 user=vpxuser:VSPHERE.LOCAL\Administrator] Throw vmodl.fault.SystemError
[YYYY-MM-DDTHH:MM:SS] info hostd[2099747] [Originator@6876 sub=Solo.Vmomi opID=56476aec-8f-f2f5 user=vpxuser:VSPHERE.LOCAL\Administrator] Result:
--> (vmodl.fault.SystemError) {
-->    reason = "Internal error",
-->    msg = "",
--> }
  • This could also present as a "no space left on device error" in hostd.log
    • Running esxcli system syslog config get gives the following error
      Got no data from process: LANG=en_US.UTF-8 /usr/lib/vmware/vmsyslog/bin/esxcfg-syslog --plugin=esxcli --list=global
    • tail /var/log/.vmsyslogd.err Shows the following 
      File "/build/mts/release/bora-9298722/bora/build/esx/release/vmvisor/sys-boot/lib64/python3.5/site-packages/vmsyslog/loggers/file.py", line 379, in writeLog
      File "/build/mts/release/bora-9298722/bora/build/esx/release/vmvisor/sys-boot/lib64/python3.5/subprocess.py", line 676, in __init__
      File "/build/mts/release/bora-9298722/bora/build/esx/release/vmvisor/sys-boot/lib64/python3.5/subprocess.py", line 1221, in _execute_child
      OSError: [Errno 28] No space left on device
      [YYYY-MM-DDTHH:MM:SS] vmsyslog.loggers.file : ERROR ] Failed to spawn onrotate call
      Traceback (most recent call last):
      File "/build/mts/release/bora-9298722/bora/build/esx/release/vmvisor/sys-boot/lib64/python3.5/site-packages/vmsyslog/loggers/file.py", line 379, in writeLog
      File "/build/mts/release/bora-9298722/bora/build/esx/release/vmvisor/sys-boot/lib64/python3.5/subprocess.py", line 676, in __init__
      File "/build/mts/release/bora-9298722/bora/build/esx/release/vmvisor/sys-boot/lib64/python3.5/subprocess.py", line 1221, in _execute_child
      OSError: [Errno 28] No space left on device
    • Checking df -h OR vdf doesn't show any full disks.

Environment

VMware vSphere ESXi 7.x
VMware vCenter Server 7.0.x

Cause

Invalid parameter(Syslog.global.LogHost) value or an issue with the configured syslog server

or 

Failed syslogd process on the host

Resolution

  1. Verify if a valid syslog server is configured in Syslog.global.LogHost.
  2. Check the network connectivity status between ESXi and the syslog server.
  3. Verify if name resolving for the syslog server FQDN is functioning correctly.
  4. Check if port 514 (UDP) is blocked by the firewall.

If it's a no space left on device error and df -h; vdf doesn't show any full disks

1. Kill the syslogd process

kill -9 `ps -Cuv | grep syslog | awk '{print $1}'`

2. Then try to reconfigure syslog or check syslog configuration again:

esxcli system syslog config get

3. If you get the same error, syslogd service may need to be restarted as well.

/usr/lib/vmware/vmsyslog/bin/vmsyslogd

Additional Information