VMware vRealize Business Fails when running 'monit restart all'
book
Article ID: 321866
calendar_today
Updated On:
Products
VMware Aria Suite
Issue/Introduction
Symptoms: When running monit restart all getting the following message:
There is no service named "[vRB Server Hostname]"
Environment
VMware vRealize Business for Cloud Standard 7.x VMware vRealize Business for Cloud Advanced 7.x VMware vRealize Business for Cloud 7.5.x
Cause
This is caused when the Hostname for the VM is changed. The monit service for the system will have the original name for the hostname. When running 'monit restart all' it picks up the current hostname as the system service and displays the message There is no service named "[vRB Server Hostname]".
Resolution
In order to update the Hostname for the System Service please perform the following:
Run the command to see the current value for the System process:
monit status
Note: Shows the last service show "System 'vrb shortname'"
Run the command to update the System process to the current configuration
monit reload
Note: Will show the message - Reinitializing monit daemon
Run the command to confirm System process is updated
monit status
Note: Shows the last service as matching the hostname "System 'vrb FQDN'"
The command monit restart all will now succeed without error.
Additional Information
To be alerted when this article is updated, click the subscribe button [cid:[email protected]] . For more information on KB subscription features, see the Knowledge Base Article FAQs: How to Subscribe to VMware Knowledge Base Articles (76417).