Unlock the admin account for the management UI
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Unlock the admin account for the management UI

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Article ID: 321834

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Updated On:

Products

VMware Integrated OpenStack

Issue/Introduction

Environment

6.x, 7.x

Cause

The management interface can be locked out for login due to too many failed attempts.  The number of failed logins to trigger this is 10.  There is only one account that can login, so failed logins are all against that account.

Resolution

We will need to check for an existing Kubernetes secret in the deployment, and delete the secret if it does exist. This will unlock the account so we can log into the management interface.

  1. SSH as root into the management server for VMware Integrated OpenStack.
  2. Check for the secret with this command: osctl edit secret webui-config
  3. If there are failed logins, there will be a line like
data:
  login_error_count: MQ==
Note: The value is base64 encoded.
  1. Remove the line with login_error_count
  2. Re-attempt logging into the management interface.

If there are continued failures despite the change, please open a case with Broadcom support.