Health check vCenter unreachable: Could not resolve FQDN
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Article ID: 321792
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Updated On:
Products
VMware Integrated OpenStack
Issue/Introduction
- Health check connectivity alerts like:
| connectivity | Alarms:2 | 1. vCenter unreachable: | | 1. Check LDAP Certificate |
| | Skipped:3 | vcenter.vio.local | | expiry status 2. Check vCenter |
| | Passed:6 | 2. Could not resolve FQDN: | | Certificate expiry status 3. |
- Ping from Manager resolves vCenter FQDN
- nslookup resolves vCenter FQDN (uses UDP)
- Openstack is functioning normally
Cause
The connectivity check script uses dig +TCP (Use TCP when querying name servers)
Resolution
Addressed in 7.3
Workaround:
Add an entry in /etc/hosts with the details of the FQDN for vCenter to have the issue resolved temporarily.
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