HCX - Migration Cutover may not trigger as per scheduled Switchover Window
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HCX - Migration Cutover may not trigger as per scheduled Switchover Window

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Article ID: 321654

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Updated On:

Products

VMware HCX VMware Cloud on AWS

Issue/Introduction

  • HCX migration did not start at the scheduled time as per the scheduled Switchover Window.
  • During the HCX migration workflow, the scheduled switchover window may lapse, causing the cutover to not trigger at the scheduled date and time. As a result, the migration will be declared as failed.

Environment

HCX

Cause

HCX Migration workflow uses "Mobility Tracker Job" which is responsible to trigger switchover.
A MigrationTracker job is created as soon as migration is initiated. For a successful migration, this job should remain active throughout the migration phase until completion which monitors and assists in transitioning a migration from one state to another.
The job can be affected if the services were down due to system issues (storage, CPU, Memory). In such cases restart of services, after clearing system issues, should recover the job automatically.

Resolution

  • Ensure that the HCX Manager is not constrained by storage CPU or memory issues at both the appliance level and the ESXi host.
  • Restart HCX services after clearing system issues, should recover the job automatically.
  • If the migration has already failed due to exceeding the switchover time, restart the migration.

Additional Information

When using Bulk or RAV (Replication Assisted vMotion) migration, enable 'Seed Checkpoint'. In the event that a migration is unsuccessful or canceled, Seed Checkpoint retains the target disks created at the target site. Without Seed Checkpoint, the HCX roll back process cleans up the target disks created during the migration and all transferred data is lost.

For more information, please access: HCX - Health Check and Best Practices