This document is created as a reference to handle MON switchover workflow for a VM which is not visible at Connector/OnPrem side.
Symptoms: Workload VM already migrated and connected to an extended segment at Cloud/dst won't appear in the Network Extension (NE) wizard at Connector/Onprem, but remain visible at Cloud side. Note: In the given conditions, VM details will remain visible in the API call obtained in HAR file captured via browser dev console at the Connector/OnPrem side.
Cause
When a VM gets migrated to cloud/dst side, a new MoRef ID(e.g: vm-xxxx) allocated for that VM by target vCenter post instantiation. Note: It is quite possible to have same MoRef ID also allocated for another VM at OnPrem/Source side due to different instance of vCenter.
Incase, MoRef ID for the migrated VM matches with another VM at OnPrem/Connector environment, then OnPrem HCX Manager won't be able to differentiate those VMs based on their MoRef ID, as a result the migrated VM won't appear in the OnPrem/Connector HCX NE wizard.
Resolution
This issue is fixed in HCX 4.6.1 release.
Workaround: User can open a Service Request with VMware Global Support Services and include the required information to work on remediation.
Additional Information
Impact/Risks:
Mobility Optimized Networking (MON) GW switchover operation won't be executed due to absence of Migrated VM at the source NE wizard. As result, the migrated VM will continue using OnPrem default GW for routed segment.
There won't be any impact in stretch/unstretch functionality for a given extended segment.