Migration validation failure "Disk size is not a multiple of 1024. RAV/Bulk migration is not supported"
search cancel

Migration validation failure "Disk size is not a multiple of 1024. RAV/Bulk migration is not supported"

book

Article ID: 321628

calendar_today

Updated On: 04-25-2025

Products

VMware HCX VMware Cloud on AWS

Issue/Introduction

Identify a known condition in the VM that will prevent HCX Bulk/RAV migrations from executing and provide the procedure to correct the VM settings.
  • Bulk/RAV migration cannot be performed for the affected VM.
  • During HCX Bulk/RAV migration validation, the following error message may appear:
    Disk size is not a multiple of 1024. RAV/Bulk migration is not supported

Environment

VMware HCX

Cause

The size of a vmdk in the VM may be configured with an odd size and/or with decimal values.
This is often due to 3rd party backup solutions that back-up the disk seed.
The appended disk value is part of the tool's validation of the byte value.

Resolution

The changes to the VM's vmdk configuration must be performed through vCenter before the HCX migration workflow.

Workaround:

IMPORTANT: In HCX version prior to 4.3 or earlier, The verification was done to verify if disk size is in multiple of 1024 bytes only.
From HCX version 4.4 or later, additional checks on disk sizes has been done, as shown below:

  • If the disk size is 2TB or less, the new size must be an exact multiple of 8KB
  • If the disk size is between 2-8TB, the new size must be an exact multiple of 16KB
  • If the disk size is between 8-32TB, the new size must be an exact multiple of 32KB
  • If the disk size is between 32-64TB, the new size must be an exact multiple of 64KB

Note: [1KB = 1024byte]

Please refer to the chart below for further clarity:

Disk Size Range Block Size Required (B)
≤ 2 TB 8 KB (8 × 1024 = 8,192 bytes)
> 2 TB and ≤ 8 TB 16 KB (16 × 1024 = 16,384 bytes)
> 8 TB and ≤ 32 TB 32 KB (32 × 1024 = 32,768 bytes)
> 32 TB and ≤ 64 TB 64 KB (64 × 1024 = 65,536 bytes)


 
Manual workaround steps:
Prerequisite: ensure no backups are running on the source VM, and disable all backup operations temporarily.

1.  Access the vCenter with the source affected VM name (object) --> Select "Actions" --> Select "Edit Settings.."

2.  In the disk hardware configuration section for the disks, ensure that the disk values are in multiples of 8KB (8192 bytes) if the disk size is less than 2 TB. Use the modulus operator (%) to check if the remainder of division is zero:

  • If disk_size(in bytes) % 8192 == 0, if remainder is 0, then it's a multiple of 8192.
  • Otherwise, if the disk size is not a multiple of 8192, then we need to adjust the size of the disk, so that it becomes the multiple of 8192, you need to increase the disk size to a value which would be N, (N = 8192 - remainder) and now if you add the disk_size(in bytes) with N, you will get a New_disk_size which would be a multiple of 8192.

See below example:

Note: the seen UI is cut-off and actually has an appended at the end, integers '558794' at the end being " 1.8100000000558794 TB" these disks 7 and 8 would need to be identified as 8192 bytes.



3.  Select the dropdown and change the disk sizing category from TB --> GB (sizing type) to add an appropriate integer value (without any trailing decimal point values).  In the above example, a value of 1855 GB was used to resolve the issue

4.  Click the "OK" button to save the VM settings

5.  Retry HCX migration validation, and it should pass (log-out and log-in may assist with any unexpected web-browsing caching)


For RDMS:

Change the Disk size from the Storage end. 




Additional Information