HCX - Fail to configure Mobility Agent host after SM/IX 4.4.0 upgrade : Connection timed out
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HCX - Fail to configure Mobility Agent host after SM/IX 4.4.0 upgrade : Connection timed out

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Article ID: 321617

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Updated On: 08-29-2024

Products

VMware HCX VMware Cloud on AWS

Issue/Introduction

This resource is to inform about MA deployment failure during HCX service mesh upgrade workflow and how to recover that.

Symptoms:
As part of SM/IX appliance version upgrade to 4.4.0, The Mobility Agent (MA) deployment may fail on a given SM due to following reasons:

2022-07-25 04:26:37.479 UTC [InterconnectService_SvcThread-15704, SM:servicemesh-########-####-####-####-##########67, IX:########-####-####-####-##########8e, J:b91edab7, , TxId: TxId: ########-####-####-####-##########00] ERROR c.v.v.h.s.i.InterconnectConfigureMA- Configure Mobility Agent job failed
java.net.ConnectException: Connection timed out (Connection timed out)

Location of App Engine log:

  • HCX Manager : /common/log/admin/app.log



Cause

This can be considered as a timing issue with MA deployment workflow experienced during SM/IX appliance 4.4.0 upgrade.

Resolution

This timing condition is fixed in HCX 4.4.1 release.

Workaround:
To help recover the MA deployment failure, user needs to trigger "Resync" operation from connector/source side for the SM where MA deployment failed during initial 4.4.0 upgrade workflow.

Additional Information

Impact/Risks:
This will only impact SM/IX appliance 4.4.0 upgrade workflow which has vMotion/RAV services enabled prior to upgrade.
A SM enabled with Bulk Migration/OSAM/DR services will remain unaffected.
NE appliance upgrade will remain unaffected.
vMotion/Cold & RAV migration will not be functional due to issues with MA deployment.
There will be NO impact to vSR Bulk Migration.