HCX Recovery process after vCenter redeployment
search cancel

HCX Recovery process after vCenter redeployment

book

Article ID: 321614

calendar_today

Updated On:

Products

VMware HCX

Issue/Introduction

  • This document is created as a reference for the recovery process of HCX services, in the unlikely event of a total loss of vCenter and restoration from a backup is not available. If a new instance of vCenter has to be installed, HCX will also have to be completely redeployed in order to restore full functionality.
  • Lost of vCenter services results in partial or complete disruption of HCX services. Migration or configuration workflows may fail.

Cause

HCX leverages the unique identifiers (UUIDs) within the specific vCenter instance in order to manage the entire inventory of network and VM objects. Because of this, an existing HCX Cloud Manager or Connector cannot be registered to a different vCenter instance without database objects becoming out of sync. Attempting to do that will result in a UUID mismatch.

Resolution

  • Redeployment of HCX is required for the Data Center environment where vCenter was lost.
  • Configuration workflows from HCX UI may fail so manual removal of HCX infrastructure may be required.
  • IX, WO, NE, and Connector or Cloud Manager VMs, will have to be removed from the new vCenter.
  • On the remote site, forced removal of Network Extensions, Service Mesh components, and Site Pairing from the HCX UI will have to be performed.
  • Workaround:
    • Restore vCenter from a backup to maintain the UUID and inventory data in sync with HCX database.

      Note: Post restoration of vCenter performed using backup OR snapshot, vCenter services should be re-registered with HCX from Appliance-management 9443 UI followed by app-engine and web-engine restart to re-sync the inventory data.

Additional Information

  • While HCX appliances will continue to run during a loss of vCenter services, existing HCX services will have to be recreated upon redeployment of the HCX Cloud Manager or Connector.
  • Migration services will no longer be available since up to date information from vCenter inventory is required to schedule any new workflows but Network Extension connectivity will remain as long as there are no immediate changes to the underlying network infrastructure, so redeployment of HCX can be planned during a maintenance window to minimize service impact.