HCX - VM with Sentinel agent installed does not show in HCX inventory
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HCX - VM with Sentinel agent installed does not show in HCX inventory

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Article ID: 321565

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Updated On:

Products

VMware HCX

Issue/Introduction

Help identify a known issue that prevents the migration of a VM with OSAM.

Symptoms:
Under certain circumstances a VM with HCX Sentinel agent installed will not show as candidate for OSAM in HCX UI. The issue can be confirmed by reviewing the logs. 

Sentinel logs:
==========
ERROR [Thread-3] c.v.h.F.ManagerReSTServer$RestAPIHandler - Error getting system configuration
java.lang.NumberFormatException: For input string: "5003571993"

HCX app.log:
===========================
app.log:2021-03-23 15:41:23.669 UTC [SentinelInventoryService_SvcThread-8449, Ent: HybridityAdmin, , TxId: ########-####-####-####-########d63d] ERROR c.v.v.h.s.s.QuerySentinelInventoryJob- Exception while trying to get configuration for sentinel ########-####-####-####-########7ef7: com.vmware.vchs.hybridity.adapters.https.HttpRequestException: Status code=500, reason=Internal Server Error, result=

Cause

The Sentinel agent experiences an exception when parsing CPU statistics due to the integer length when the GuestOS uptime is very long.
IMPORTANT: This issue happens in HCX release 4.0.0 and it affects VMs running Linux Guest OS only. Previous releases and Windows Guest OS are not impacted.




Resolution

This issue is resolved in VMware NSX 4.0.1


Workaround:
If at all possible, the VM could be rebooted to reset the uptime.

Additional Information

Impact/Risks:
This issue prevents the Sentinel agent from getting the VM configuration required to include it in the HCX inventory for OSAM.