Organization vDC statistics (cpu, mem, storage) do not reflect the actual usage
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Organization vDC statistics (cpu, mem, storage) do not reflect the actual usage

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Article ID: 321465

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • Organization vDC statistics (cpu, mem, storage) do not reflect the actual usage.
  • This article can also be used to fix the slowness issue in Cloud Director by clearing the inventory tables and followed by vCenter reconnect.

Environment

VMware Cloud Director 10.6.x

Cause

This issue can present itself if the Cloud Director Cells are not shut down properly.

Resolution

Note: A Snapshot of all the cells and a database backup is advised before making any changes.

  1. SSH to Primary Cloud Director Cell as root.
  2. Run the following command to check on the status of the DatabaseCacheRefreshJob:

    /opt/vmware/vcloud-director/bin/cell-management-tool cell -i $(service vmware-vcd pid cell) -tt | grep DatabaseCacheRefreshJob

  3. If the task is not running on the Primary Cell, SSH as root to the other Cells and run the same command from step 2.
  4. This task should be found once on only one of the Cells in the cluster.
  5. If the service is not running once on any of the Cells, a restart of the Cloud Director service on the Cells should rectify the issue.
  6. To restart the Cloud Director service on the Cells, SSH to each Cell in turn and run the following commands:
    NOTE: The Cloud Director UI will be unavailable from a Cell while the service is restarting. A rolling restart of the Cloud Director service on Cells behind a load balancer can be used to minimise disruption.

    Stop the service on a Cell:

    /opt/vmware/vcloud-director/bin/cell-management-tool cell -i $(service vmware-vcd pid cell) -s

    systemctl stop vmware-vcd

    Start the service on a Cell:

    systemctl start vmware-vcd

  7. After restarting the Cloud Director service on all Cells, SSH as root to all the Cells and run the same command from step 2. 
  8. Confirm that the DatabaseCacheRefreshJob is running once on one of the Cells in the cluster.
  9. Refresh the Cloud Director UI to verify if the correct statistics are now shown.

If the issue persists after a restart of the Cloud Director services, open a case with Broadcom support and reference this KB 321465.