Virtual Machine deployment and Power ON tasks fail in VMware Cloud Director Tenants
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Virtual Machine deployment and Power ON tasks fail in VMware Cloud Director Tenants

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Article ID: 321454

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • Unable to perform deployment actions in tenant UI.
  • vApp/VM Power On task either completes successfully in VCD(VMware Cloud Director) without reaching vCenter or times out after a long time with following error:

    [ ########-####-####-####-############ ] The vCenter Server operation ([vcId=########-####-####-####-############, moref=task-######) has taken too long (900000.00 seconds). VMware Cloud Director considers this operation timed out.

  • In vCenter Server, there is no power ON task for the VM, only an Initialize powering On/Reconfigure virtual machine task is observed
  • In the /opt/vmware/vcloud-director/logs/vcloud-container-debug.log, messages are seen as:

2023-03-17 16:56:23,415 | WARN | vim-proxy-activity-pool-23 | PowerOnVmActivity | [Activity Execution] Timed out while waiting for VMs [[vcId=UUID, moref=vm-####]] status to change to powered on in the inventory cache. Waited 300 seconds for the VMs status to change to > powered on. - Handle: urn:uuid:########-####-####-####-############ | requestId=<REQUEST_UUID>,request=POST https://vcloud.example.com/api/vApp/vm-<VM_UUID>/power/action/powerOn,requestTime=1679071877867,remoteAddress=<IP>:60159,userAgent=Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTM...,accept=application/*+xml;version 38.0.0-alpha vcd=<VDC_UUID>,task=<TASK_UUID> activity=(com.vmware.vcloud.backendbase.management.system.TaskActivity,urn:uuid:<TASK_ACTIVITY_UUID>) activity=(com.vmware.ssdc.backend.PowerOnVmActivity,urn:uuid:<TASK_ACTIVITY_UUID>) activity=(com.vmware.vcloud.fabric.foundation.vm.impl.PowerOperationActivity,urn:uuid:<TASK_ACTIVITY_UUID>) activity=(com.vmware.vcloud.val.internal.impl.PowerOnVmActivity,urn:uuid:<TASK_ACTIVITY_UUID>)

Environment

VMware Cloud Director

Cause

This issue occurs when the DRS setting in vCenter cluster is set to Manual.
VMware Cloud Director does not support the power on function of VMs when DRS automation level is set to Manual in vCenter.

Resolution

To resolve the issue, change the vSphere DRS automation level from Manual to Partially Automated or Fully automated. 
For more details, please refer 'vSphere Configuration Requirements'  here -  VMware Cloud Director Hardware and Software Requirements.

 

Additional Information