"The VMware Cloud Director entity XXX already exists." error observed when attempting to add a user in the Cloud Director UI.
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"The VMware Cloud Director entity XXX already exists." error observed when attempting to add a user in the Cloud Director UI.

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Article ID: 321447

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

Symptoms:
  • "The VMware Cloud Director entity XXX already exists." error when adding a user.
  • Cannot add a user in Cloud Director.


Environment

VMware Cloud Director 10.x

Cause

This issue occurs when there are Stale entries present in the database referencing the user you are attempting to add. 

Resolution

To resolve this issue, attempt the workaround below to remove the unwanted user from the API Explorer. 

If the user is not present from the API Explorer, please open a Support Request with VMware Technical Support and reference this KB article.
 
Database modifications may be required to resolve this issue and will require VMware Technical Support assistance.

Workaround:
  1. Navigate to the API Explorer.
  2. Locate the 'User' section.
  3. Run a 'GET/1.0.0/users' to list all users:
  4. Click 'Try It Out', then 'Execute' to list all users.
  5. Verify the user from the error message is present in this list.
  6. If the user is present, copy the user's URN ID
e.g. urn:vcloud:user:<USER_UUID>
  1. Run a 'DELETE /1.0.0/users/{userUrn}' using the URN ID of the user above.
 



If the user is not present in the list returned in Step 3, please open a Support Request with VMware Technical Support and reference this KB article.