Error: "VMware Syslog Collector failed with error code '3010'" when upgrading vCenter Server
search cancel

Error: "VMware Syslog Collector failed with error code '3010'" when upgrading vCenter Server

book

Article ID: 321332

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • Windows vCenter Server 6.x upgrade fails with the error:
"Installation of component Syslog Collector failed with error code '3010'. Check the logs for more details"
  • In pkgmgr-comp-msi.log, you see entries similar to:
MSI (s) (3C:D4) [19:27:38:452]: Verifying accessibility of file: messages.dll
MSI (s) (3C:D4) [19:27:38:452]: Note: 1: 2318 2:  
MSI (s) (3C:D4) [19:27:38:452]: Note: 1: 2318 2:  
Info 1603.The file C:\Program Files\VMware\vCenter Server\vmsyslogcollector\bin\messages.dll is being held in use.  Close that application and retry.

Environment

  • VMware vCenter Server 6.7.x
  • VMware vCenter Server 6.0.x
  • VMware vCenter Server 6.5.x

Cause

This issue is caused by a process holding a lock on a required dll file.

Resolution

To resolve this issue follow the steps below:

  1. Disable any running antivirus and backup software
  2. Then retry the vCenter Server upgrade

If the issue persists, follow these steps:

  1. Download and install the Microsoft Process Explorer and check if the dll files referenced in the pkgmgr-comp-msi.log are locked.
  2. Stop the service or halt the process that is holding the lock on the dll file(s).​
  3. Open C:\Program Files\VMware\vCenter Server\vmsyslogcollector\bin in File Explorer.
  4. Create a copy of any locked dll file(s) and rename them to end with ".old".
  5. Retry the upgrade.