And under catalina.out/stdout.log file found following error message:
Error occurred while creating a request/problem/incident. AxisFault faultCode: {http://schemas.xmlsoap.org/soap/envelope/}Server faultSubcode: faultString: faultActor: faultNode: faultDetail: {}ErrorMessage:null {}ErrorCode:1
After enabling debug at Service Desk side, it shows following error under log file:
09/04 16:31:23:36 PRDSDMSC1 domsrvr 9552 ERROR sec_mgr.c 4475 Error in DomSession 538612839 in method session_registered: 10 register_session_user failed;
Environment
CA Service Desk 17.1 RU1 CA Spectrum 10.3
Cause
This is usually related to the session_log table having a session number which had already been used previously or somehow the user/SOAP Web Services Policy designated to be performing the integration is not configured properly on the CA Service Desk side.
Resolution
You can archive/purge the session_log, but if it is not possible the following is suggested:
1) Install the following variable in NX.ENV:
@NX_SESSION_LOG_EXCLUDE=ALL
This setting disables sesssion_log table entries - that is, any new logins will not be added to the table.
2) Here are the commands to be executed on the CA Service Desk side:
pdm_options_mgr -c -s SESSION_LOG_EXCLUDE -v ALL -a pdm_option.inst pdm_options_mgr -c -s SESSION_LOG_EXCLUDE -v ALL -a pdm_option.inst -t
3) Review the SOAP Web Services Policy and the user designed to be performing this integration. There are cases where changing the integration for another user can fix this issue.
4) CA Service Desk must be restarted after running these commands.