“Agent VIB module not installed” when installing EAM/VXLAN Agent using VUM
search cancel

“Agent VIB module not installed” when installing EAM/VXLAN Agent using VUM

book

Article ID: 321227

calendar_today

Updated On:

Products

VMware vCenter Server VMware vSphere ESXi VMware NSX

Issue/Introduction

Symptoms:

  • Installing or uninstalling the VXLAN agent fails with the error:

    Agent VIB module not installed
     
  • Deploying VMware VXLAN-enabled vSphere Distributed Switched to your vSphere environment using vSphere Update Manager fails

Note: For additional symptoms and log entries, see the Additional Information section.

Environment

VMware NSX for vSphere 6.3.x
VMware vSphere Update Manager 5.5.x
VMware vShield Manager 5.1.x
VMware NSX for vSphere 6.2.x
VMware NSX for vSphere 6.1.x
VMware vSphere Update Manager 5.1.x
VMware NSX for vSphere 6.0.x

Cause

This issue occurs if vSphere Update Manager (VUM) is unavailable. EAM depends on VUM to approve the installation or uninstallation of VIBs to and from the ESXi host.

Resolution

This is a known issue affecting NSX for vSphere 6.x
 
This issue is resolved in vSphere 6.0 Update 3

To work around this issue, install the VXLAN module directly on the ESXi host.

Note: Before proceeding, ensure that the bypassVumEnabled flag is set to true. This setting configures the EAM to install the vibs directly to the ESXi hosts even when the VUM is installed and/or not available.
 
To modify the flag and to ensure that the installation completes:
  1. Open a browser to the MOB at:

    https://<vCenter_Server_IP>/eam/mob/

    Note: If this is a new installation of vCenter Server, log in to https://vCenter_Server_IP/eam using a web browser to deploy the EAM.
     
  2. Log in with Administrator privileges.
  3. Select an agency from the agency list. This is usually agency-0. If not, select the appropriate agency.

    Note: In VMware vCenter Server 6.0, the agencies have changed to GUID.
     
  4. Click Config. This should be a URL where agency-0 is replaced by your local agency ID.

    For example:

    https://<vCenter_Server_IP>/eam/mob/?moid=agency-0&doPath=config
     
  5. Verify if the bypassVumEnabled flag is set to true.
  6. If the value is set to true, proceed with installing the VXLAN modules and preparing the host.
  7. If the flag is set to false:
     
    1. Using the agency ID identified in Step 3, change the browser URL:

      https://<vCenter_Server_IP>/eam/mob/?moid=agency-<0>&method=Update
       
    2. In the config field, change the existing configuration options to match this:

      <config>
      <bypassVumEnabled>true</bypassVumEnabled>
      </config>

       
    3. Click Invoke Method. Result should match: Method Invocation Result: void

      Note: Click Resolve on the Host Preparation tab in the NSX Manager UI if the agency is in a Red State.
Note: In all other cases, leave the setting as true to allow newly installed hosts that join the cluster to work seamlessly.



Additional Information

  • Deploying VMware VXLAN-enabled vSphere Distributed Switched to your vSphere environment using vSphere Update Manager fails
  • While preparing a host to install or uninstall the VXLAN agent, a task in vCenter Server displays the error:

    enable agent, cannot complete the operation, see the event log for details
     
  • In the host.event log file, you see the error:

    VIB module for agent is not install on host vmwarehost1 vShield-VXLAN-Service
     
  • In the ESX Agent Manager (EAM) in vCenter Server, the status of vShield Manager solution is Red when the host fails to prepare
  • EAM reports the error:

    Agent VIB module not installed