VMware vRealize Automation becomes unresponsive on regular intervals
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VMware vRealize Automation becomes unresponsive on regular intervals

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Article ID: 321199

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
VMware vRealize Automation becomes unresponsive with high CPU usage for about an hour on regular intervals (every 12 or 24 hours).

Environment

VMware vRealize Automation 8.1.x

Cause

This issue occurs in the provisioning-service telemetry in VMware vRealize Automation 8.1 that may lead to high CPU usage making the system unresponsive.

Resolution

This is a known issue affecting VMware vRealize Automation 8.1.x.

Currently, there is no resolution.

Workaround:
To work around this issue, disable the provisioning-service telemetry.
  1. Log in through SSH in the vRealize Automation appliance.
  2. Backup the deployment.yaml file located in /opt/charts/provisioning-service/templates/ by copying it to the /root folder by running this command:

    vracli cluster exec -- bash -c "cp /opt/charts/provisioning-service/templates/deployment.yaml /root"
     
  3. Disable provisioning-service telemetry by running this command:

    vracli cluster exec -- bash -c "sed -i '/name: ENABLE_TELEMETRY/,/value/s/value: .*/value: \"false\"/' /opt/charts/provisioning-service/templates/deployment.yaml"

    Note: The part around ENABLE_TELEMETRY setting in /opt/charts/provisioning-service/templates/deployment.yaml should look like:

    name: ENABLE_TELEMETRY
    value: "false"

     
  4. Run this command:

    /opt/scripts/deploy.sh
     
  5. Wait until the system is re-initialized (About 20 minutes).