vSphere Cloud Account resource enumeration gets stuck and new resources are not discovered
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vSphere Cloud Account resource enumeration gets stuck and new resources are not discovered

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Article ID: 321198

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

This article provides information on resolving stuck vSphere Cloud resource enumeration.

Symptoms:
  • vSphere Cloud Account resource enumeration gets stuck and new resources are not discovered.
  • A message starts to appear in the Provisioning Service logs regularly for periods longer than an hour regarding a particular vSphere Cloud Account similar to:

    Enumeration for endpoint is in progress, new enumeration request will be ignored


Environment

VMware vRealize Automation 8.1.x

Cause

This issue occurs due to an unforeseen problem which causes the enumeration process to get stuck.

Resolution

This is a known issue affecting VMware vRealize Automation 8.1, 8.1 P1 and 8.1 P2.

Currently, there is no resolution.

Workaround:
To work around this issue, restart the vRA pod on the HA system in used:

Note: In order to minimize the impact of restarting the vRA pod on the HA system in used:
  1. Disable the load balancer traffic to one vRA node, where the pod will be restarted, by setting its pool member to offline/disabled state.
  2. Give a few minutes, so that new/incoming requests are sent over to the other vRA nodes and then restart the Provisioning Service pod on the disabled node.

    To find out which pod runs on which node use this command: 

    kubectl -n prelude get pods -o wide

    To restart the pod use this command: 

    kubectl -n prelude delete pod provisioning-service-app-<POD_ID> by replacing the POD_ID with the desired value
     
  3. Enable the load balancer traffic to the disabled/offline node.
  4. Complete the same steps for another vRA node.