Cannot download NSX Tech Support logs if short month contains an accented letter
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Cannot download NSX Tech Support logs if short month contains an accented letter

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Article ID: 321071

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Updated On:

Products

VMware NSX for vSphere

Issue/Introduction

Symptoms:
  • Downloading the Tech Support logs from the NSX Manager fails.
  • You see the error similar to:

    error: Invalid Operation
     
  • The NSX Manager uses a locale different than US.
  • The short name of the current month contains an accented letter.
  • The vsm.log file contains entries similar to:

    2018-02-22 17:02:45.947 GMT  INFO https-jsse-nio-443-exec-5 TechSupportBundlor:116 - - [root@nsx comp="nsx-manager" subcomp="manager"] Tech support bundle generated by script /tmp/VMware-NSX-Manager-tech-support-2018févr.22--17-02-38-097892632.tar.gz

    vsm.log shows the Tech Support log bundle is attempted to be downloaded with a garbled accented character:

    2018-02-22 17:02:51.069 GMT  INFO https-jsse-nio-443-exec-9 TechSupportC


    Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.


Environment

VMware NSX for vSphere 6.3.x

Cause

This issue occurs due to a character encoding issue.

Resolution

This is a known issue affecting VMware NSX for vSphere 6.3.x.

Currently, there in no resolution.

Workaround:
To work around this issue, generate and export the Tech Support logs through the CLI command using the export tech-support scp destination command from enable mode.

For example:

NSX# export tech-support scp root@scpserver:/tmp/