Hardware Support Manager requires Latin-1-only vCenter Server username for firmware and driver information
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Hardware Support Manager requires Latin-1-only vCenter Server username for firmware and driver information

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Article ID: 321055

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

Symptoms:

  • In the "Select Firmware and Drivers" dialog, after selecting a hardware support manager, no hardware support packages appear.
  • In the hwsupportmgr.log file, you see entries similar to:

    HardwareSupportManagerCtl : XXXX-XX-XX XX:XX:XX,562 hwsupportmgrctl:197 ERROR Unexpected error occurred during execution: 'latin-1' codec can't encode characters in position 0-3: ordinal not in range(256).
    HardwareSupportManagerCtl : XXXX-XX-XX XX:XX:XX,563 hwsupportmgrctl:205 ERROR Error code: 60



Environment

VMware vCenter Server 7.0.x

Cause

This issue occurs due to an attempt to use an unencoded vCenter Server username as-is for the value of an HTTP header that is defined in the HTTP standard as "Latin-1".  As a result, when a user with a VC username that contains non-Latin-1 characters tries to do something that involves interacting with an HSM, the failure then occurs.

Resolution

This issue is resolved in VMware vCenter Server 7.0 Update 1, available at ProductFiles - Support Portal - Broadcom support portal

Workaround:
To work around this issue if you do not want to upgrade, only attempt HSM interactions (defining a vLCM cluster's Desired Image, scanning for compliance, or remediating a cluster) when logged in as a user whose name is strictly Latin-1 compliant.