The vSphere Client (H5 client) is showing error stack traces
book
Article ID: 321005
calendar_today
Updated On:
Products
VMware vSphere ESXi
Issue/Introduction
This article provides information to customers with very security sensitive environments in which the returned stack traces might be an issue.
Symptoms:
HTTP requests that have hit an error during processing return a stack trace.
Cause
This issue occurs due to the default mode of the H5 client which is to return the stack traces for debug purposes.
Resolution
To resolve this issue, put
error.stackTrace.show=false in the
webclient.properties.
- Navigate to /etc/vmware/vsphere-ui/webclient.properties.
- Edit the file webclient.properties.
- Go to end of the file and add a line "error.stackTrace.show = false".
- Save and Exit the webclient.properties file.
- Restart the vsphere-ui service.
Note: This option is available since vSphere 6.5.
Feedback
thumb_up
Yes
thumb_down
No