Host profile status displays as "Not Compliant" after clicking REMEDIATE on an ESXi 7.x host
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Host profile status displays as "Not Compliant" after clicking REMEDIATE on an ESXi 7.x host

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Article ID: 321001

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Symptoms:
On an stateful and stateless ESXi 7.x host that has Syslog.global.logDir configured with a custom path other than the default [] /scratch/logs, after clicking on the REMEDIATE button in the CONFIGURE > Host Profile option, you see these symptoms:

  • Host profile status displays as "Not Compliant" after a reboot. The impacted host prior to the reboot was previously displaying a status of Compliant.
  • In the [] /dastore/logs/hostname a duplicate hostname folder exist.
  • In the /var/log/syslog.log of the impacted ESXi host, you see entries similar to:

    2022-11-29T12:33:29Z Host Profiles[2110285 opID=7e92ea12-02-SWI-2a3593-60-911e]:             value = 'Syslog.global.logDir'                }             ],             message = "Option Syslog.global.logDir doesn't match the specified criteria"          },          expressionName = 'option["key-vim-profile-host-OptionProfile-Syslog_global_logDir"]-optionFixed',          failureValues = (vim.profile.ComplianceResult.ComplianceFailure.ComplianceFailureValues) [             (vim.profile.ComplianceResult.ComplianceFailure.ComplianceFailureValues) {                dynamicType = <unset>,                dynamicProperty = (vmodl.DynamicProperty) [],                comparisonIdentifier = 'Value-[Syslog.global.logDir]',                profileInstance = <unset>,                hostValue = '[Datastore] scratch/hostname,                profileValue = '[Datastore] scratch'             }          ]       }    ] }
     
  • In the /var/log/vmware/vpxd/vpxd.log, you see entries similar to:

    2022-11-29T12:33:30.054Z info vpxd[10312] [Originator@6876 sub=moHostProfile opID=7e92ea12-02] [CheckCompliance]: Host Hostname is not compliant with profile HostProfileName: (vim.profile.ComplianceResult.ComplianceFail
    ure) [
    -->    (vim.profile.ComplianceResult.ComplianceFailure) {
    -->       failureType = "Option.Mismatch",
    -->       message = (vmodl.LocalizableMessage) {
    -->          key = "com.vmware.vim.profile.ComplianceFailure.Option.Mismatch.label",
    -->          arg = (vmodl.KeyAnyValue) [
    -->             (vmodl.KeyAnyValue) {
    -->                key = "key",
    -->                value = "Syslog.global.logDir"
    -->             }
    -->          ],
    -->          message = "Option Syslog.global.logDir doesn't match the specified criteria"
    -->       },
    -->       expressionName = "option["key-vim-profile-host-OptionProfile-Syslog_global_logDir"]-optionFixed",
    -->       failureValues = (vim.profile.ComplianceResult.ComplianceFailure.ComplianceFailureValues) [
    -->          (vim.profile.ComplianceResult.ComplianceFailure.ComplianceFailureValues) {
    -->             comparisonIdentifier = "Value-[Syslog.global.logDir]",
    -->             profileInstance = <unset>,
    -->             hostValue = "[Datastore] logs/hostname",
    -->             profileValue = "[Datastore] logs"
    -->          }
    -->       ]
    -->    }
    --> ]


    For additional information, see Location of vCenter Server log files (1021804) .



Environment

VMware vSphere ESXI 7.0.x

Cause

This issue occurs due to a race condition on the impacted ESXi host that are attach to a Host Profile.

Resolution

This is a known issue affecting VMware ESXi 7.x.

Currently, there is no resolution.

Workaround:
To work around this issue:

  1. On the impacted ESXi host, Navigate to Advanced Settings > Remove "hostname" in front of [Datastore] folder in "Syslog.global.logDir".
  2. Set the Syslog.global.logDirUnique to false.
  3. Click REMEDIATE.
  4. Test by rebooting the impacted ESXi host and confirm that it is now Compliant.