NSX Manager backup fails
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NSX Manager backup fails

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Article ID: 320954

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Updated On:

Products

VMware NSX

Issue/Introduction

Symptoms:
After changing backup settings, you experience these symptoms:
  • NSX Manager backup fails.
  • Appliance management User Interface (UI) hangs or reloads the entire page asking again for credentials.
  • In the NSX Manager logs, you see entries similar to:

    2017-09-28 12:30:02.424 GMT ERROR http-nio-443-exec-208 FtpSftpUtils:223 - Unable to connect to server 10.91.235.127 at 22.
    Either server details are invalid or invalid credentials are presented.
    com.jscape.filetransfer.FileTransferException: Java heap space
    ...
    Caused by: java.lang.OutOfMemoryError: Java heap space


    Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.


Cause

This issue occurs due to an issue with the jscape library that is used for SFTP connection.

Resolution

This is a known issue affecting VMware NSX for vSphere 6.3.x.

Currently, there is no resolution.

Workaround:
To work around this issue:
  1. Fetch the backup settings using the API call to ensure that the backup settings were configured correctly:

    GET https://NSXMGR_IP/api/1.0/appliance-management/backuprestore/backupsettings

    In response, you should get the existing settings that were configured.
     
  2. Execute this REST API call,which deletes the existing backup settings:

    DELETE https://NSXMGR_IP/api/1.0/appliance-management/backuprestore/backupsettings

    Alternatively, use the curl command:

    curl -k -u 'admin:default' -H 'Accept: application/xml' -H 'Content-type: application/xml' -X DELETE 'https://NSXMGR_IP/api/1.0/appliance-management/backuprestore/backupsettings')
     
  3. Attempt to get the settings using the API call:

    GET https://NSXMGR_IP/api/1.0/appliance-management/backuprestore/backupsettings

    In response, you should not get anything , which implies that there is no backup server configured.
     
  4. Try to log in the NSX  Manager Appliance management User Interface (UI), and try configuring the backup settings again.