Upgrading Aria Automation using Aria Lifecycle Manager gives error "IP '##.##.##.##' does not uniquely resolve to Hostname 'example.com'"
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Upgrading Aria Automation using Aria Lifecycle Manager gives error "IP '##.##.##.##' does not uniquely resolve to Hostname 'example.com'"

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Article ID: 320610

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

During the pre-check for upgrading Aria Automation from one version to another, users may encounter an error stating "IP '##.##.##.##' does not uniquely resolve to Hostname 'example.com' "

  • Pre-check for upgrade of Aria Automation fails.
  • Error message indicates IP address and hostname mismatch.
  • nslookup of the IP address may resolve to the correct hostname with different capitalization (e.g., all uppercase).

Environment

VMware Aria Suite Lifecycle 8.x
VMware Aria Automation 8.x

Cause

This issue is caused by a bug in Aria Lifecycle version 8.14 that only recognizes hostnames in lowercase during the pre-check.

 

Resolution

  1. Apply Patch 1 to Aria Lifecycle 8.14: This patch resolves the bug and allows the pre-check to recognize hostnames with different capitalization formats.
  2. Rerun the pre-check: After applying the patch, rerun the pre-check for the upgrade. It should now pass successfully.

Additional Information