Cloud Director Cell Service not starting post upgrade
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Cloud Director Cell Service not starting post upgrade

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Article ID: 320535

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

Symptoms:
  • After upgrading Cloud Director, the vmware-vcd* services do not start
  • The log file /opt/vmware/vcloud-director/logs/cell.log is empty
  • Cloud Director cell status is inactive in UI
  • You will see the following in the log file /opt/vmware/vcloud-director/logs/vmware-vcd-watchdog.log
    • 2020-06-08 15:24:02 | INFO  | vmware-vcd-cell running [This will log at INFO every 5 status checks while vmware-vcd-cell is running]
    • 2020-06-08 15:24:02 | WARN  | wget failed, return code: 4, will retry in 30 seconds

 


Environment

VMware Cloud Director for Service Provider 10.x
VMware Cloud Director for Service Provider 9.x

Cause

This issue occurs when Cloud Director tries to use a cached version of certain files upon service start.

Resolution

This is resolved in VMware Cloud Director 10.2 and above.

Workaround:
To workaround this issue, we need to clean up the cached files and restart the Cloud Director Service.
Please follow the below steps:

  1. cd $VCLOUD_HOME/etc/
  2. rm -rf org.eclipse.*
  3. service vmware-vcd restart
  4. Repeat this on all Cells