"AssertionConsumerServiceIndex cannot be set when ProtocolBinding or AssertionConsumerServiceUrl are set." when logging in with an imported SAML user
book
Article ID: 320534
calendar_today
Updated On:
Products
VMware Cloud Director
Issue/Introduction
Symptoms:
Federated Users cannot login to vCloud Director.
SSO Users cannot login to vCloud Director.
When vCloud Director is configured with a SAML Identity Provider and the imported user is trying to login, it will fail with error "AssertionConsumerServiceIndex cannot be set when ProtocolBinding or AssertionConsumerServiceUrl are set."
Environment
VMware Cloud Director for Service Provider 10.x VMware Cloud Director for Service Provider 9.x
Cause
This issue occurs because of the way vCloud Director generates Authentication Requests.
Resolution
This is a known issue affecting vCloud Director for Service Providers 10.0
Workaround: There currently no workaround available for this issue