book
Article ID: 320517
calendar_today
Updated On:
Environment
VMware Cloud Director 10.x
VMware Cloud Director for Service Provider 10.x
Cause
This issue is caused by accumulation of sockets from a load balancer connecting to TCP Port 8443, the port used by console proxy service.
As a result, this accumulation leads to an exhaustion of file descriptors and memory.
Resolution
This is a known issue in Cloud Director 10.1 and later.
Workaround:
- Load balancers should monitor only TCP Port 443, the port used by the HTTP and API Interface of the Cell.
- The API endpoint for monitoring whether this service is up should also be leveraged.
- HTTP Request: GET /api/server_status
- HTTP Response: Service is up.
Additional Information
For information on how to Load Balance Cloud Director with NSX-T, you can refer to the link below:
Load Balancing vCloud Director with NSX-T