VM memory reservation gets resets to 0MB after a hard disk replacement in a Reservation Pool Virtual Data Center"
search cancel

VM memory reservation gets resets to 0MB after a hard disk replacement in a Reservation Pool Virtual Data Center"

book

Article ID: 320499

calendar_today

Updated On:

Products

VMware Cloud Director

Issue/Introduction

Symptoms:
  • Memory Reservation resets to 0MB post hard disk change for a VM in Reservation Pool Virtual Data Center.
  • Memory Reservation resets to 0MB when VM hard disk is edited on an Organization Virtual Data Center backed by Reservation Pool model.
  • VM Memory Reservation is 0MB after making changes to a VMs Hard Disks.
  • Machines in Reservation vDCs have their Memory Reservations reset after updating Hard Disks.


Environment

VMware Cloud Director for Service Provider 10.x

Cause

The issue arises due to the absence of a custom Compute Profile within the Reservation Mode

Resolution

This is a Known Issue in VMware Cloud Director 10.3.x.
This issue is resolved in VMware Cloud Director 10.4  available at Broadcom Download Portal  

Workaround:

Virtual Machines within a Reservation Model have their reservation values set manually.
To revert the Virtual Machine to it's desired state after making a change to the attached hard disk, manually set the memory reservations to the intended value.

  1. Login to the Tenant Portal.
  2. Locate the Virtual data center.
  3. Click on the Details of the affected VM.
  4. Navigate to Hardware > Advanced section.
  5. Click Edit and set the Reservation values.
  6. Click Save.