If a SAML Single Logout (SLO) process is triggered from another SSO Consumer, vCloud Director is not correctly forwarding the response to the Identity Provider to complete the logout for all SSO consumers
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If a SAML Single Logout (SLO) process is triggered from another SSO Consumer, vCloud Director is not correctly forwarding the response to the Identity Provider to complete the logout for all SSO consumers

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Article ID: 320488

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

Symptoms:
  • vCloud Director is preventing a Single Logout (SLO) process from completing.
  • If a SAML Single Logout (SLO) is triggered via vCloud Director, the process completes without issues
  • You are logged out of vCloud Director, however vCloud Director redirects you the Organizations login page instead of to the Identity Provider.


Environment

VMware Cloud Director for Service Provider 9.x

Cause

  • This issue occurs because vCloud Director is not forwarding the response to the Identity Provider to complete the logout.

Resolution

  • This is a known issue affecting vCloud Director for Service Providers.


Workaround:
  • To work around this issue, initiate the SAML Single Logout (SLO) from vCloud Director.
  • This will complete the SSO chain of events correctly and you will be logged out of all entities successfully.