Error: "The operation failed because no suitable resource was found... Compute requirement not met" when deploying VMs
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Error: "The operation failed because no suitable resource was found... Compute requirement not met" when deploying VMs

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Article ID: 320485

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • Any VM/vApp operations from the VMware Cloud Director (VCD) UI fails with the error

"The operation failed because no suitable resource was found. Out of 1 candidate hubs: 1 hubs eliminated because: Compute requirement not met"

  • Failed tasks in the VCD UI state that a hardware version was not available:

The operation failed because no suitable resource was found. Out of # candidate hubs: 
# hubs eliminated because: Compute requirement not met: [type:HardwareVersion, value:vmx-##].  Rejected hubs: resgroup-####
- PlacementException NO_FEASIBLE_PLACEMENT_SOLUTION

  • In the /opt/vmware/vcloud-director/logs/vcloud-container-debug.log, entries of the type as below are seen

    "NO_FEASIBLE_PLACEMENT_SOLUTION" due to "Exception while trying to retrieve hardware version"
    "ResourcePoolComputeFinder      | Internal Error: Filtering out hub since hardware version is not available"

Environment

VMware Cloud Director 10.4.x and later 

Cause

This is a known issue in VMware Cloud Director versions 10.4.x and later.

After upgrade the cluster_compute_resource_ext database table is missing one or more entries allowing Cloud Director to validate the hardware versions applicable to the deploying clusters.

Another possible reason for the issue is the inventory collector agent on the cells being stuck causing missing entries in the table.

Resolution

Currently there is no resolution.

To workaround this issue log into the VCD Provider Portal and perform a Reconnect operation on the vCenter Server where the VM is to be created.
See the documentation for more information on this operation, Reconnect a vCenter Instance to Your VMware Cloud Director.
NOTE: After the Reconnect task on the vCenter completes in VCD, it can take some time for all the hardware version information to completely repopulate with the data from vCenter and the issue to be resolved.

If the issue persists after a Reconnect on the vCenter then perform the following workaround to force VCD to re-evaluate the ESXi cluster hardware version support:

  1. From the vSphere UI, place one of the ESXi hosts into maintenance mode.
  2. Take the ESXi host back out of maintenance mode.
  3. The change in state will trigger an update, causing VCD to reprocess the Hosts and their respective clusters. This will update/add the missing record into the cluster_compute_resource_ext table.