Cloud Director hangs when leveraging VMware vSAN NFS as the Transfer Share
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Cloud Director hangs when leveraging VMware vSAN NFS as the Transfer Share

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Article ID: 320473

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Updated On:

Products

VMware Cloud Director VMware vSAN

Issue/Introduction

Symptoms:

  • VMware Cloud Director hangs when leveraging VSAN NFS as the Transfer Share.
  • vSAN NFS v3 and v4.1 shares appear stuck or locked when using Cloud Director.

Environment

VMware vSAN 7.0.x

Cause

This issue occurs when delegation is enabled for file services.

Resolution

This is a known issue with VMware vSAN 7.0.3.

Workaround:

To work around this issue, please disable Delegation.

  1. Find the UUIDs associated with the ganesha.conf file
    1. find /vmfs/volumes/vdfsDatastore/. -name ganesha.conf
  2. The UUIDs will be in XXX, YYY and ZZZ format
  3. Edit the ganesha.conf file on the ESXi host which is mounted to:
    1. /vmfs/volumes/vdfsDatastore/XXX/volumes/YYY/default/ZZZ/nfs1/etc/ganesha.conf
  4. The conf file edit set Delegations to none and false.

NFS_CORE_PARAM { MNT_Port = 20048; Rquota_Port = 875; Plugins_Dir = /usr/lib/ganesha; Enable_FULLV3_Stats = true; Enable_FULLV4_Stats = true; Dbus_Name_Prefix = nfs1; mount

EXPORT_DEFAULTS { Delegations = None; Protocols = 3,4; SecType = sys; }

NFSV4 { Delegations = false; Minor_Versions = 1; Lease_Lifetime = 60; Grace_Period = 90; Only_Numeric_Owners = true; }

NFS_KRB5 { CCacheDir = /var/run/ganesha; }

MDCACHE { LRU_Run_Interval = 60; FD_Limit_Percent = 7; FD_HWMark_Percent = 1; FD_LWMark_Percent = 0; Entries_HWMark = 102400; Reaper_Work_Per_Lane = 200; }

LOG { FORMAT { CLIENTIP = true; LEVEL = false; FILE_NAME = false; LINE_NUM = true; time_format = none; date_format = user_defined; user_date_format = "%Y-%m-%dT%H:%M:%SZ";

EXPORT { Export_Id = 100; Path = "/vsfs/########-####-####-####-########b012/volumes/30a6e24d-e597-####-####-########97d/default"; Pseudo = "/vcd-vcf1"; Access_Type = None

EXPORT { Export_Id = 101; Path = "/vdfs_rootfs_mnt/########-####-####-####-########dac5/volumes/0da7dc40-de33-####-####-########45b/default/6f59d066-6e39-4d63-af31-6ac7070

  1. Restart the vsanmgmtd service:
    1. /etc/init.d/vsanmgmtd restart