The vmware-vcd service becomes stuck in a restart loop following a restart of the service.
search cancel

The vmware-vcd service becomes stuck in a restart loop following a restart of the service.

book

Article ID: 320467

calendar_today

Updated On:

Products

VMware Cloud Director

Issue/Introduction

Symptoms:
  • The vmware-vcd service becomes stuck in a restart loop following a restart of the service.
  • The vmware-vcd service reaches 66% before restarting.
  • In the /opt/vmware/vcloud-director/logs/cell.log the service is seen reaching 66% before restarting. This continues indefinitely.
  • In the /opt/vmware/vcloud-director/logs/vcloud-container-debug.log you can see
    Timed out waiting for service: 'userDao'



Environment

VMware Cloud Director 10.x

Cause

This issue occurs when the UserLegacyDao is too slow to instantiate during startup. As a result the startup process becomes stuck in a constant loop.

Resolution

The issue is resolved in VMware Cloud Director 10.4.1 available at Download Broadcom products and software.


Workaround:

The only available workaround is to redeploy the affected cell.

Please refer to the following documentation:
Recover from a Standby Cell Failure in a High Availability Cluster