"VM XXXX failed to update and has been rolled back. Internal Server Error" when moving VMs between vApps in VMware Cloud Director.
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"VM XXXX failed to update and has been rolled back. Internal Server Error" when moving VMs between vApps in VMware Cloud Director.

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Article ID: 320425

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • "VM XXXX failed to update and has been rolled back. Internal Server Error Internal Server Error" when moving VMs between vApps from an NSX-V to NSX-T environment in VMware Cloud Director.
  • Failing to move vApps using the API call https://vcloud.example.com/api/vdc/xxxx/action/moveVApp from an NSX-V to NSX-T environment in VMware Cloud Director.
  • Similar error when moving VM from one Org VDC to another Org VDC within the same Organization. 
  • Within /opt/vmware/vcloud-director/logs/vcloud-container-debug.log, the following log snippet can be seen:
| ERROR    | Backend-activity-pool | MoveVAppActivity               | [Activity Execution] Move VApp failed due to an error, deallocating IPs - Handle: urn:uuid:xxxx, Current Phase: MoveVAppActivity$FinalPhase | requestId=xxxx,request=POST https://vcloud.example.com/api/vdc/xxxx/action/moveVApp,requestTime=1664265967785,remoteAddress=x.x.x.x:58132,userAgent=python-requests/2.26.0,accept=application/*;version 36.3 vcd=xxxx,task=xxxx activity=(com.vmware.vcloud.backendbase.management.system.TaskActivity,urn:uuid:https://vcloud.example.com/api/vdc/xxxx/action/moveVApp) activity=(com.vmware.vcloud.vdc.impl.MoveVAppActivity,urn:uuid:https://vcloud.example.com/api/vdc/xxxx/action/moveVApp)
java.util.concurrent.ExecutionException: com.vmware.vcloud.vdc.impl.LinkVMsToTargetVAppActivity$LinkVMsToVAppException: VM xxxx failed to update and has been rolled back. MigrateException: MIGRATION_FAILED_DESTINATION_RESOURCE_RECONFIG_FAILED VM xxxx failed to update and has been rolled back.

Environment

VMware Cloud Director 10.x

Cause

This issue occurs due to a mismatch between the computehub_id and vrp_id in the computevm table in the VMware Cloud Director database.

Resolution

To resolve this issue, contact Broadcom Technical Support and note this Knowledge Article ID (320425) in the problem description.

For more information, see How to Submit a Support Request

Database modifications is required to resolve this issue and will require VMware Technical Support assistance.