Telegraf Agent operations failing following upgrade to Aria Operations 8.14 or later
search cancel

Telegraf Agent operations failing following upgrade to Aria Operations 8.14 or later

book

Article ID: 320333

calendar_today

Updated On:

Products

VMware Aria Suite

Issue/Introduction

This article provides steps to re-establish the connection between product-managed Telegraf agents and Cloud Proxies for VMware Aria Operations 8.14.x and higher versions when the Cloud Proxy is not upgraded.

Symptoms:

Following the upgrade to Aria Operations 8.14 or higher you may notice the following issues with product-managed agent operations if the Cloud Proxy has not been upgraded / doesn't match the Aria Operations version:

  • Discovered services are not listed for existing product-managed Telegraf agents.
  • Add/edit/delete buttons for application are missing and there is no way to add new plugins.
  • Existing product-managed Telegraf agents start, stop, and update actions fail with "Agent Operation Failed: Please check the health of the Cloud Proxy and the Salt service. Retry the action if components are healthy. Agent operation failure, Control channel does not exist or could not be established. Check if VM null with UCPFQDN property CP-IP does not have a collector." warning message.
  • Product-managed Telegraf agent installation fails with "Agent Operation Failed: Please check the health of the Cloud Proxy and the Salt service. Retry the action if components are healthy. Agent operation failure, Control channel does not exist or could not be established. Check if VM VM-names with UCPFQDN property CP-IP does not have a collector." warning message.
  • Data collection is successful.


Cause

Before VMware Aria Operations onprem 8.14.0 version, the telegraf agent management operations and monitoring were handled by "Physical ARC - CP-name" and "VCIPorFQDN-ARC-ADAPTER-CP-name" adapters.

Starting from Aria Operations 8.14,
  • "Physical ARC - CP-name" will be converted to "Application Monitoring Adapter - CP-name" adapter,
  • "VCIPorFQDN-ARC-ADAPTER-CP-name" adapter will be deleted and instead of it a new vCenter-CloudProxy mapping will be used in VMware Aria Operation cluster. 
  • The Telegraf agent management operations will be handled by the "Application Monitoring Adapter - CP-name" adapter and new agent installation will be forwarded to corresponding CP based on vCenter-CloudProxy mapping.

If the cloud proxy is not upgraded and doesn't match with VMware Aria Operations version, then "Application Monitoring Adapter - CP-name" adapter and vCenter-CloudProxy mapping will not exist and product-managed Telegraf agent related operations will fail.

Resolution

  • Upgrade cloud proxy by using VMware Aria Operations Cloud Proxy recovery script to recover cloud proxy
  • If the existing cloud proxy is not upgraded and new VMs on vCenter need to be monitored for application monitoring with another cloud proxy with version 8.14 or later, it can done by creating a "vCenter-Cloud Proxy" mapping for agent installation, which will use the new CP for agent installation and all other application monitoring action on these new VMs where agent is installed.
    • Using the UI:
      • Browse to Environment >> Applications >> Manage telegraf agents >> Select new VMs to be monitored >> Agent action >> Install
      • Install Telegraf agent wizard will open to select the Cloud proxy or collector group for a vCenter. 
        Select the Cloud Proxy to be used for application monitoring with version greater than 8.14, new "vCenter-Cloud Proxy" mapping will be created by selecting cloud proxy for vCenter, finally, complete the agent installation.
        Install Telegraf agent wizard will open once for a vCenter, when no cloud proxy is selected for agent installation. 
        For subsequent agent installation operations, this wizard will not be displayed and the same cloud proxy will be used for agent installation for any new agent installation operation on new VMs on vCenter.
    • Using the API:
      1. Navigate to Home in Aria Operations and click on the Developer Center link. Under API click on API documentation link.
        Note: If using Aria Operations on-prem, click the green Authorize button on the right of the page.
        If presented with an Authorized user, click Logout first, next, input the local Admin user's login information and click Authorize, then click Close.
      2. Create a "vCenter-Cloud Proxy" mapping using API POST /api/applications/vccpmappings.
        • Search for API POST /api/applications/vccpmappings, then expand it.
        • Click Try it out.
        • Under Parameters click on Edit value for aiRequest. Prepare the payload as described below, provide collector uuid of cloud proxy with the list of VMEntityVCID values of vCenter. Or Provide collectorGroupId for application monitoring high availability activated collector group having CPs version greater than 8.14 along with the list of VMEntityVCID values of vCenter.  
        • {
              "vCenterMappings" : [
                  {      
                      "collectorUUID" : "########-####-####-####-############",
                      "vCenterIds" : [ "########-####-####-####-############","########-####-####-####-############" ]            
                  },
                  {                 
                      "collectorGroupId" : "########-####-####-####-############", 
                      "vCenterIds" : [ "########-####-####-####-############","########-####-####-####-############" ]          
                 }]
          }
        • Click Execute.
      3. Now perform agent installation through Suite API POST /api/applications/agents for application monitoring of new VMs to be monitored on vCenter using CP version higher than 8.14.