"Failed to run boot script" error after upgrading from vCenter Server 6.5 to 6.7
search cancel

"Failed to run boot script" error after upgrading from vCenter Server 6.5 to 6.7

book

Article ID: 320174

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

Symptoms:
  • Upgrading from vCenter Server 6.5 to 6.7 fails with the error:
"Failed to run boot script"
  • In the vminst.log file, you see entries similar to:
2018-07-31 12:42:06.592-05:00| vcsInstUtil-8546234| I: LaunchProcAndMonitorStatus: Launching "C:\Windows\system32\cmd.exe /S /C ""C:\Program Files\VMware\vCenter Server\bin\run-firstboot-scripts.bat" >> C:\Users\admin\AppData\Local\Temp\vminst-con.log 2>&1"" in "C:\Windows\system32\"
2018-07-31 12:42:06.592-05:00| vcsInstUtil-8546234| I: LaunchProcAndMonitorStatus: Launched process with pid 15744 tid 18212
2018-07-31 12:42:06.592-05:00| vcsInstUtil-8546234| I: Entering function: MonitorStatusFile
2018-07-31 12:42:06.592-05:00| vcsInstUtil-8546234| I: MonitorStatusFile: Status file directory is "C:\ProgramData\VMware\vCenterServer\logs\firstboot\"
2018-07-31 12:42:06.592-05:00| vcsInstUtil-8546234| I: MonitorStatusFile: Monitoring directory "C:\ProgramData\VMware\vCenterServer\logs\firstboot\" for file "fbInstall.json"
2018-07-31 12:42:06.592-05:00| vcsInstUtil-8546234| I: MonitorStatusFile: Started execution of process
2018-07-31 12:42:18.062-05:00| vcsInstUtil-8546234| I: MonitorStatusFile: Other process terminated with 1, exiting
2018-07-31 12:42:18.062-05:00| vcsInstUtil-8546234| I: MonitorStatusFile: Calling status parser one last time
.
2018-07-31 12:42:18.062-05:00| vcsInstUtil-8546234| E: LaunchProcAndMonitorStatus: Failure detected while monitoring status file
.
2018-07-31 12:42:18.062-05:00| vcsInstUtil-8546234| E: RunFirstLastUpdateboot: Failed to run boot script: "C:\Windows\system32\cmd.exe /S /C ""C:\Program Files\VMware\vCenter Server\bin\run-firstboot-scripts.bat" >> C:\Users\admin\AppData\Local\Temp\vminst-con.log 2>&1""
 
  • In the vminst-con.log file, you see entries similar to:
[Error 3] The system cannot find the path specified: 'c:\\programdata\\vmware\\vcenterserver\\runtime\\vsphere-client\\server\\workspace\\logbrowser\\.vmwb\\logbrowser\\cache\\0x1.7463f05c93a64p-1\\509820290d57f333403f490dde7316f4\\vc-vcenter-2017-03-23--13.08-15016\\programdata\\vmware\\vcenterserver\\logs\\vsphere-client\\logs/*.*'
.
2018-07-31T17:42:08.311Z  Running command: ['C:\\Windows\\system32\\icacls.exe', 'C:\\ProgramData\\VMware\\vCenterServer', '/grant:r', '*S-1-5-18:(OI)(CI)(F)', '/grant:r', '*S-1-5-32-544:(OI)(CI)(F)', '/inheritance:r', '/L', '/Q']
2018-07-31T17:42:09.702Z  Done running command
2018-07-31T17:42:09.702Z  Running command: ['C:\\Windows\\system32\\icacls.exe', 'C:\\ProgramData\\VMware\\vCenterServer\\*', '/reset', '/T', '/L', '/Q']
2018-07-31T17:42:18.031Z  Done running command
2018-07-31T17:42:18.031Z  Invoked command: ['C:\\Windows\\system32\\icacls.exe', 'C:\\ProgramData\\VMware\\vCenterServer\\*', '/reset', '/T', '/L', '/Q']
2018-07-31T17:42:18.031Z  RC = 3
Stdout = Successfully processed 11682 files; Failed processing 1 files^M
.
.
Stderr = C:\ProgramData\VMware\vCenterServer\runtime\vsphere-client\server\workspace\logbrowser\.vmwb\LogBrowser\cache\0x1.7463f05c93a64p-1\509820290d57f333403f490dde7316f4\vc-vCenter-2017-03-23--13.08-15016\ProgramData\VMware\vCenterServer\logs\vsphere-client\logs\vsphere_client_virgo.log: The system cannot find the path specified.^M
.
Error Code: 1021
2018-07-31T17:42:35.207Z  Running command: ['C:\\Program Files\\VMware\\vCenter Server\\bin\\run-firstboot-scripts.bat', '--action', 'firstboot', '--subaction', 'uninstall', '--logDirectory', 'C:\\ProgramData\\VMware\\vCenterServer\\logs\\uninstall']


Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.


Environment

VMware vCenter Server 6.5.x
VMware vCenter Server 6.7.x

Cause

This issue occurs when upgrade script tries to reset permission using icacls and fails due to the long file path (more than MAXLIMIT 260 letters).

Resolution

To resolve this issue:

It is a best practice to take a snapshot of vCenter Server before performing below steps.
  1. Move all contents of long file path to a temp location.
Note: Upgrade script must remove these files during uninstall phase, if these file are not removed upgrade fails.
 
For example, move all log-browser cache files from C:\ProgramData\VMware\vCenterServer\runtime\vsphere-client\server\workspace\logbrowser\.vmwb\LogBrowser\cache\ folder to a temp location.
  1. Stop vsphere-client service.
  2. Open the cmd and run the icacls C:\ProgramData\VMware\vCenterServer\runtime\vsphere-client /reset /T /L /Q and ensure it completes without failures.
Note: Run the icacls command as per the file path found in the vminst-con.log.
  1. Start vsphere-client service and upgrade process again.