Harbor enablement failed with 400 bad request
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Harbor enablement failed with 400 bad request

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Article ID: 320114

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

Symptoms:

In the admin-agent log, you see message similar to:

"msg="failed to update system admin password for registry harbor-1459587925: 400 Bad Request:{\"code\":400,\"message\":\"the password or secret must longer than 8 chars with at least 1 uppercase letter, 1 lowercase letter and 1 number\"}\n""

Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.


Environment

VMware vCenter Server 7.0.x

Cause

This issue is caused when the password generated does not match Harbor requirement.

Resolution

To resolve this issue, Disable and re-enable Harbor registry, see Enable the Registry Service for vSphere with Kubernetes in Region A
Note: Disable and re-enable Harbor registry if the issue re-occurs.