"Unable to contact the source vCenter" error at pre-check when upgrading vCenter Server Appliance from 6.5 to 6.7
search cancel

"Unable to contact the source vCenter" error at pre-check when upgrading vCenter Server Appliance from 6.5 to 6.7

book

Article ID: 320109

calendar_today

Updated On:

Products

VMware vCenter Server VMware vCenter Server 6.0

Issue/Introduction

  • Upgrading vCenter Server Appliance(VCSA) from 6.5 to 6.7 fails with the error:
Unable to contact the source vCenter
  • In C:\Users\<USERNAME>\AppData\Local\Temp\installer-xxxxxxxx-xxxxxxxxx.log you may see entries similar to:
 
YYYY-MM-DDTHH:MM:SS.052Z - info: VM Identifier for Source VC: 1048 
YYYY-MM-DDTHH:MM:SS.176Z - debug: initiateFileTransferFromGuest error: ServerFaultCode: Failed to authenticate with the guest operating system using the supplied credentials. 
YYYY-MM-DDTHH:MM:SS.176Z - debug: Failed to get fileTransferInfo:ServerFaultCode: Failed to authenticate with the guest operating system using the supplied credentials. 
YYYY-MM-DDTHH:MM:SS.176Z - debug: Failed to get url of file in guest vm:ServerFaultCode: Failed to authenticate with the guest operating system using the supplied credentials. 
YYYY-MM-DDTHH:MM:SS.176Z - error: Error in getting fileData for nodeType. Error: ServerFaultCode: Failed to authenticate with the guest operating system using the supplied credentials. 
YYYY-MM-DDTHH:MM:SS.177Z - error: Failed to read the nodetype, Error: Failed to authenticate with the guest operating system using the supplied credentials. 
 
Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.

Cause

This issue occurs when the vCenter OS password ( root password ) is expired.

Resolution

To resolve this issue, reset the password.

 

Process to Reset the Password:
 

To reset the password follow the steps below:

  1. Connect to the source vCenter using SSH.
  2. Execute "chage -l root"  command to check if the root password has expired
  3. Change the password using the command "passwd"
  4. Initiate the upgrade again
Note: If SSH access is not available, see Resetting root password in vCenter Server Appliance