' Disk Usage of the system is very high at 90%. To avoid failures please extend storage from system details page' error present in LCM
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' Disk Usage of the system is very high at 90%. To avoid failures please extend storage from system details page' error present in LCM

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Article ID: 320038

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:

  • Aria Lifecycle Data disk space has reached more than 90%, and the UI shows the disk storage alert;
    •  Disk Usage of the system is very high at 90%. To avoid failures please extend storage from system details page.
  • Aria Lifecycle Root partition has filled almost 100%, Aria Lifecycle may stop processing any requests, and all the requests will start failing once submitted.
  • Uploading patch binaries fail as the /data partition is full (100% utilized) due to the accumulation of outdated patch binaries within the patches, temp, and tempextract directories.



Environment

Aria Lifecycle (Formerly LCM) 8.x

Cause

Aria Lifecycle Data disk might have filled due to multiple downloads such as product install & upgrade binaries, patch binaries, Marketplace binaries, content downloads, log bundle downloads, etc.

Aria Lifecycle root disk space of LCM VA has reached 100%, and subsequently causes Aria lifecycle to stop processing any request.

To confirm, run the 'df -h' command and verify:

root@lcm-hostname [ ~ ]# df -h
Filesystem Size Used Avail Use% Mounted on
devtmpfs 7.9G 0 7.9G 0% /dev
tmpfs 7.9G 8.0K 7.9G 1% /dev/shm
tmpfs 7.9G 852K 7.9G 1% /run
tmpfs 7.9G 0 7.9G 0% /sys/fs/cgroup
/dev/sda3 19G 19G 0 100% /
tmpfs 7.9G 11M 7.9G 1% /tmp
/dev/mapper/data_vg-data 99G 95G 4G 95% /data
/dev/sda1 120M 31M 84M 27% /boot

 

Resolution

To resolve this issue, clean up the Aria Lifecycle data disk:

The 'Product Binaries' Page can be found by navigating through the following menus;

  • Lifecycle Operations
  • Settings (In the left-hand pop-out menu)
  • Product Mapping

The following actions are possible from this menu.

  • You can use the 'Delete' button on each product patch listed under the 'Product Patches' on the binaries page; it will delete the downloaded/uploaded product patches from the /data/patches/ folder.
  • The 'Delete Unsupported Binaries' button will remove all unsupported Binaries from the instance.

Alternatively the following steps can be attempted

  • You can use the 'Delete' option in the 'Available' tab of the Marketplace page, which will delete the downloaded content from the /data/marketplace/content/ folder.
  • SSH to Aria Lifecycle appliance using root credentials, and some content can be cleaned up from the /data directory as follows:
    • Aria products' old support log bundles can be removed from the directory /data/support-bundle/
    • Unused or old Customer Connect product binaries can be removed from the directory /data/Customer Connect