Distributed Resource Scheduler cluster reports the error: DRS Invocation Not Completed
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Distributed Resource Scheduler cluster reports the error: DRS Invocation Not Completed

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Article ID: 320016

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Updated On: 02-12-2025

Products

VMware vCenter Server

Issue/Introduction

Symptoms:
  • vCenter Server reports this error on the VMware Distributed Resource Scheduler (DRS) cluster:

    DRS Invocation Not Completed
     
  • DRS does not function as expected
  • DRS fails to migrate virtual machines
  • This issue does not occur when the VMware DRS mode is set to Manual


Cause

This issue may occur if exclusive locks are held on multiple hosts in DRS cluster when creating the new Virtual Machine File System (VMFS) datastore.

DRS also needs to lock these hosts, but cannot lock them because they are already locked. In this case, the VMware DRS invocations fail to complete.

Resolution

To resolve this issue:

  1. Increase the logging level of vCenter Server. By default, vCenter Server is configured for info logging. Increase the logging level to Trivia.

    For more information, see Enabling trivia logging in VMware vCenter Server.

  2. Reproduce the issue on the affected DRS cluster.
  3. Collect logs from vCenter Server. For more information, see Collecting diagnostic information for VMware vCenter Server 7.x and 8.x.

After you collect the logging information, file a Support Request. For more information, see Creating and managing Broadcom support cases.

To work around this issue, perform these steps. The steps are ordered in the most appropriate sequence to isolate the issue and identify the proper workaround. Do not skip a step. If one of the steps is not successful, do not continue with the workarounds.
  1. Verify your NTP and DNS configuration:

    1. Verify that the NTP is configured and working on vCenter Server and all hosts in the cluster. For more information, see Troubleshooting NTP on ESX and ESXi 6.x / 7.x / 8.x.
    2. Verify that the DNS is configured and working on all hosts in the cluster. For more information, see Identifying issues with and setting up DNS name resolution on ESXi Server.

  2. Disable and re-enable vSphere HA for the affected cluster. For more information, see Disabling VMware High Availability (HA).

  3. Perform a rolling restart of the management agents on the affected hosts:


    1. From the first affected host, restart the management agents. For more information, see Restarting the Management agents in ESXi.
    2. When the host is reconnected to vCenter Server, restart the management agents on the next host.
    3. Repeat this process until all affected hosts are restarted.

  4. Disconnect and reconnect the affected hosts.

    1. Right-click the host and click Disconnect. Wait for the ESXi/ESX host to completely disconnect.
    2. Right-click the host and click Reconnect. Wait for the ESXi/ESX host to completely connect.
    3. Repeat this process until all affected hosts are disconnected and reconnected.

  5. Place the ESXi/ESX host into maintenance mode and restart the vCenter Server services.

    1. Right-click the host and select Enter Maintenance Mode. Wait for all virtual machines to evacuate the host.
    2. Restart the VirtualCenter Server Service. For more information, see How to stop, start, or restart vCenter Server services.

  6. Reboot vCenter Server.



Additional Information