How to remove a stale VxRail Manager from SDDC DB
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How to remove a stale VxRail Manager from SDDC DB

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Article ID: 319845

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Updated On:

Products

VMware Cloud Foundation

Issue/Introduction

Troubleshooting various scenarios where someone may have manually deleted the VxRail VM or a cluster without SDDC intervention.


Symptoms:

Stale VxRail Manager entries within the SDDC DB can break many different workflows (upgrades, host/cluster add/removals etc.).

This can also cause the SDDC UI to not load properly.

Environment

VMware Cloud Foundation 5.x

VMware Cloud Foundation 4.x

Cause

Internal workflow duplicates the entry or the VxRail VM was manually deleted or redeployed out-of-band

Resolution

Confirm that there are multiple entries for the same VxRail Manager in the SDDC Manager DB:

 

  1. SSH to SDDC Manager as 'root'
  2. Run the following command to save the output vx_manager table

psql -h localhost -U postgres -d platform -c "select * from vx_manager;" > /tmp/vxmanagers.txt 

  • Identifying the Older Entry:

Find the duplicate VxRail Manager information from the table in /tmp/vxmanagers.txt

Convert creation_time to human readable time: Use an online epoch converter (like https://www.epochconverter.com/).

Compare timestamps: The entry with the older timestamp is the one to delete.

Contact GS to complete the removal task as it will require editing multiple tables in platform DB.

Additional Information

Impact/Risks: 

Editing the SDDC Manager database manually is a process that requires taking precautions such as snapshot or a full image backup of the SDDC Manager VM