Internet Explorer 11 display issues in vRealize Log Insight 8.1
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Internet Explorer 11 display issues in vRealize Log Insight 8.1

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Article ID: 319590

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
  • vRealize Log Insight 8.1 is being accessed with Internet Explorer 11.
  • The User icon on the header, and chart legend list display in Dashboards and Interactive Analytics experience layout issues.


Environment

VMware vRealize Log Insight 8.1.x

Cause

This is a known issue affecting vRealize Log Insight 8.1 in Internet Explorer 11.
No other browsers experience these issues.

Resolution

To resolve the issue, edit the CSS files to correct the layout.
  1. Log into the vRealize Log Insight Primary Node as root via SSH or Console.
Note: Type ALT+F1 in a Console to log in.
  1. Open /usr/lib/loginsight/application/3rd_party/apache-tomcat-8.5.51/webapps/ROOT/loginsight/base/clarity-override.css in a text editor.
Example: vi /usr/lib/loginsight/application/3rd_party/apache-tomcat-8.5.51/webapps/ROOT/loginsight/base/clarity-override.css
  1. Find the #header-icon-user CCSS Style.
  2. Replace left:unset with left:24px.
Example#header-icon-user{left:24px}
  1. Save and close the file.
  2. Open /usr/lib/loginsight/application/3rd_party/apache-tomcat-8.5.51/webapps/ROOT/js/widgets-yui3/style/pi-widgets-yui3.css in a text editor.
  3. Find the .highcharts-legend-item>span{display:block; CSS Style.
  4. Replace float:left with height: 16px; padding-right: 20px;.
Example.highcharts-legend-item>span{display:block;height: 16px; padding-right: 20px;}
  1. Save and close the file.
  2. Repeat steps 1-9 on all other nodes in the cluster.
Once the changes are complete, refresh the pages in the UI to show the corrected layout.