Reset the Admin User Password in vRealize Log Insight 4.7
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Reset the Admin User Password in vRealize Log Insight 4.7

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Article ID: 319588

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
  • Running li-reset-admin-passwd.sh in vRealize Log Insight 4.7 fails with the error:
Connection error: ('Unable to connect to any servers', {'127.0.0.1': AuthenticationFailed('Remote end requires authentication.',)})
ERROR: unable to get salt


Environment

VMware vRealize Log Insight 4.7.x

Cause

Due to the Cassandra authentication introduced in vRealize Log Insight 4.7, the script fails to log into Cassandra.

Resolution

To resolve the issue, update the script and provide the Cassandra username and password.

  1. Download the attached li-reset-admin-passwd.sh script.
  2. Copy li-reset-admin-passwd.sh to /opt/vmware/bin on each node using an SCP utility; overwriting the existing li-reset-admin-passwd.sh in that directory.
  3. Log into the vRealize Log Insight Primary node as root via SSH or Console.
  4. Run the following command to set permissions on the script:
chmod 755 /opt/vmware/bin/li-reset-admin-passwd.sh
  1. Repeat steps 3-4 on all nodes in the vRealize Log Insight cluster.
  2. Run the following command to get the Cassandra credentials and note the user and password values:
/usr/lib/loginsight/application/lib/apache-cassandra-3.11.2/bin/credentials-look-up

Note: You will see output similar to:
<cassandra-user value="lisuper" />
<cassandra-password value="######" />
  1. Run the following command to reset the admin password:
li-reset-admin-passwd.sh user password

Note: Replace user and password with the values noted in step 6 respectively.

Example: li-reset-admin-passwd.sh lisuper ######



Attachments

li-reset-admin-passwd.sh get_app