Upgrade from vRA 7.1 to 7.3.1 fails when Management Agents were not upgraded to new version
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Upgrade from vRA 7.1 to 7.3.1 fails when Management Agents were not upgraded to new version

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Article ID: 319577

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
  • When you perform an automatic upgrade from vRealize Automation 7.1 to 7.3.1, the upgrade fails because Management Agents were not upgraded to the new version.
  • When you navigate to the VAMI Cluster tab , you observe that there are one or more Management Agents displayed with their old version.
  • In the latest Management Agent MSI upgrade log file on respective IaaS machines, you see the entries similar to:

    Product: VMware vCloud Automation Center Management Agent -- Error 1316. The specified account already exists.

    Note: the Management Agent MSI upgrade log could be found in the following location:

    Management_Agent_install_dir\Logs\ManagementAgentUpgrade-<yyyyMMdd-HHmm>.log (for upgrades from versions prior to 7.3)

    Management_Agent_install_dir\Logs\InstallLogs-<yyyyMMddhhmmss>\ManagementAgent-Setup.log (for upgrades from version 7.3 and above)
     
  • The current Primary appliance is not the first VAMI url listed in the affected Management Agent's configuration (VMware.IaaS.Management.Agent.exe.Config) file, in section <managementEndpoints>.


Environment

VMware vRealize Automation 7.3.x

Cause

There has been failover of the vRAs and the replica nodes still have the old Management Agent installation file.

Resolution

This is a known issue when migrating VMware vRealize Automation 7.1 to 7.3.1.

Currently, there is no resolution.

Workaround:
To work around this issue, manually distribute the new Management Agent installer to all virtual appliances.

Note: Backup the current IaaS Management Agent Installer file before proceeding with below steps.
  1. Download the vRA IaaS Management Agent Installer file, available at VMware Downloads.
     
  2. Replace the downloaded IaaS Management Agent Installer file on all vRA appliances by overwriting the existing file.
    /opt/vmware/share/htdocs/service/iaas/download/vCAC-IaaSManagementAgent-Setup.msi
     
  3. Retry the automatic upgrade after replacing the correct MA MSI file.