Error is shown in Container Volumes view for guest cluster volume
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Error is shown in Container Volumes view for guest cluster volume

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Article ID: 319544

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Symptoms:
  • Container volumes displays "Failed to extract the requested data. Check vSphere Client logs for details." error message when the list contains a newly created volume in a guest cluster.
  • The specific error message from vsphere_client_virgo.log file is: 
Caused by: java.lang.IndexOutOfBoundsException: Index: 0, Size: 0
at java.util.ArrayList.rangeCheck(ArrayList.java:657)
at java.util.ArrayList.get(ArrayList.java:433)
at com.vmware.vsan.client.services.cns.VolumeFactoryImpl.addGuestClusters(VolumeFactoryImpl.java:229)
at com.vmware.vsan.client.services.cns.VolumeFactoryImpl.addNonEmptyClustersToVolume(VolumeFactoryImpl.java:217) at com.vmware.vsan.client.services.cns.VolumeFactoryImpl.updateVolume(VolumeFactoryImpl.java:51)
at com.vmware.vsan.client.services.cns.BaseVolumeFactory.createVolume(BaseVolumeFactory.java:53)
at com.vmware.vsan.client.services.cns.CnsService.createVolumes(CnsService.java:470)
at com.vmware.vsan.client.services.cns.CnsService.getVolumes(CnsService.java:203)


Environment

VMware vSphere ESXi 7.0.0

Cause

  • Container volumes UI doesn't handle properly missing K8s details that are not yet received for newly created volumes in a guest cluster.
     

Resolution

  • The volumes database may not be synced and updated at the time of loading the volumes view. Retrying to list the volumes after some time will fix the issue.