Eth0 missing in vRealize Log Insight
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Eth0 missing in vRealize Log Insight

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Article ID: 319531

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

If node status reports as inaccessible in vRealize Log Insight Cluster page, correct the MAC address of the NIC in the vRealize Log Insight node(s) to resolve the issue.

Symptoms:
  • The vRealize Log Insight Administration > ManagementCluster page shows one or more nodes as inaccessible.
  • The node loses hostname (renames to localhost).
  • When you run the command ifconfig eth0, you see the output:
eth0: error fetching interface information: Device not found


Cause

This occurs when the MAC address of the NIC has changed on the vRealize Log Insight node(s).

Resolution

To resolve this issue, correct the MAC address of the NIC in the vRealize Log Insight node(s).
Note: Before proceeding, stop the services on all the nodes before correcting the MAC address on the affected node:
  1. Log in to the Primary node as root through console.
  2. Run this command to stop the vRealize Log Insight services:
service loginsight stop
  1. Repeat steps 1 to 2 on all other nodes in the vRealize Log Insight cluster.

To correct the MAC address of the NIC in affected node:
  1. Log in to the affected vRealize Log Insight node as root through console.
  2. Copy the /etc/udev/rules.d/70-persistance-net.rules file to /tmp/70-persistance-net.rules.bak.
  3. Open the /etc/udev/rules.d/70-persistance-net.rules file using a text editor.
  4. Comment out the first SUBSYSTEM line by adding # at the beginning of the line.
Example:
#SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:50:56:03:44:77", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
  1. Change the second SUBSYSTEM line from eth1 to eth0.
Example:
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:50:56:03:35:2f", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
  1. Save and close the file.
  2. Repeat steps 1 to 6 on all affected vRealize Log Insight nodes.
  3. Restart all nodes in the vRealize Log Insight cluster.