[VMC on AWS] Could not connect to one or more vCenter Server Systems: http://onpremvcenterFQDN:443/sdk is seen while logging into vSphere client on cloud vCenter
search cancel

[VMC on AWS] Could not connect to one or more vCenter Server Systems: http://onpremvcenterFQDN:443/sdk is seen while logging into vSphere client on cloud vCenter

book

Article ID: 319497

calendar_today

Updated On:

Products

VMware Cloud on AWS

Issue/Introduction

 To understand why this issue occurs and the next plan of action.


Symptoms:

1.) Customer would have recently upgraded their on-prem VC to 8.0.x version and the cloud vCenter is at 7.0.x version.

2.) This issue can occur if the customer uses VCGW or HLM to manage On-Prem and cloud vCenters in a single pane of view.

 

image.png


Cause

It is caused due to version incompatibility between the On-Prem and Cloud vCenters.
HLM, and vSphere client on the vCenter gateway, would always have the same version as the Cloud VC (regardless of VCGW  version).
Hence in a scenario where On-Prem VC is a higher version than Cloud VC,  the vSphere client would not be forward compatible and the 7.0.3 client fails to connect to the On-Prem vCenter 8.0.x version.

Resolution

This behavior is by design while using HLM or vCenter Gateway where Cloud vCenter is on an older version than On-Prem vCenter.
To resolve this issue, upgrade the Cloud vCenter to the same or later version (e.g. M20v5)  than On-Prem vCenter.

 

Document to request for SDDC upgrade:-https://docs.vmware.com/en/VMware-Cloud-on-AWS/services/com.vmware.vmc-aws-operations/GUID-7725CAAC-BBDB-4F80-991F-1D1ADDE12216.html

Alternatively, customers can reach out to CSMs to get the SDDCs upgraded to the M20 version.


Workaround:

N/A


Additional Information

N/A


Impact/Risks:

 Not being able to manage cloud vCenter and on-prem vCenter in a single pane of view.