Error: "The supplied System Name <vCenter Server Appliance FQDN> is not valid" when attempting to upgrade or deploy vCenter Server Appliance
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Error: "The supplied System Name <vCenter Server Appliance FQDN> is not valid" when attempting to upgrade or deploy vCenter Server Appliance

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Article ID: 319490

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Updated On:

Products

VMware vCenter Server VMware vCenter Server 6.0 VMware vCenter Server 7.0

Issue/Introduction

  • Attempting to deploy a vCenter Server Appliance on versions 6.x or 7.x fails
  • Attempting to upgrade to vCenter Server Appliance 6.7 fails
  • In the /var/log/firstboot/firstbootStatus.json file, the following entry may be observed:

    "failedSteps": "visl-support-firstboot"

  • In the visl-support-firstboot.py_####_stderr.log file, the following line may be observed:

    The supplied System Name <vCenter Server Appliance FQDN> is not valid
  • In the UI, the following error is observed:

    Firstboot script execution Error. The supplied System Name vCenter_Server_FQDN is not valid.

 

For more information, please refer to Firstboot Failed during Install/Deployment, Upgrade or Migration in vCenter Server and vCenter Server Appliance 6.7

Cause

This issue occurs when the DNS record for the vCenter Server Appliance is incorrect or does not exist. This issue can also occur due to web browser cache containing previous vCenter information if there was a name change.

Resolution

To resolve this issue, verify that the FQDN has a valid (internal) domain name system (DNS) registration before upgrading vCenter Server Appliance.  

For more information about DNS requirements, see DNS Requirements for the vCenter Server Appliance and Platform Services Controller Appliance.

 

Other troubleshooting steps:

  1. Open the console to the vCenter Server Appliance and press F2 and log in with root credentials.
  2. Enable the bash shell:

    shell.set --enabled true
     
  3. Access the bash shell:

    shell
     
  4. Ping the DNS servers to confirm communication:

    ping <dns.dns_server.com>
     
  5. Use nslookup to make sure the vCenter Server Appliance and DNS Server can be resolved:

    nslookup <vCenter_Server_Appliance_FQDN>
    nslookup <DNS_Server_FQDN>

    Note: Run this against all DNS Servers configured in VCSA.

  6. Use the nslookup command to resolve the shortname.
  7. Check the hosts file for invalid DNS names:

    cat /etc/hosts

  8. Clear web browser cache.
  9. Verify that there are no underlying network connectivity issues. After the underlying network issue is resolved, attempt to deploy/upgrade the vCenter Server Appliance.