Upgrading vCenter causes Bitfusion to lose stop working and display an “Invalid Bitfusion License” error
search cancel

Upgrading vCenter causes Bitfusion to lose stop working and display an “Invalid Bitfusion License” error

book

Article ID: 319391

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Symptoms:
After protracted vCenter downtime (greater than 5 minutes), Bitfusion Servers and clusters will stop accepting client workloads and will display an “Invalid Bitfusion License” error on the Bitfusion screen in vCenter. The Bitfusion Servers will also present an error in the VM Console session indicating: "Unable to create vcenter client. Error creating vim client"
 
invalid_bitfusion_license.png

bitfusion_vcenter_connection.png


This is most commonly encountered during a vCenter upgrade due to the extended downtime required.

Environment

VMware vSphere Bitfusion 2.x

Cause

This is caused by a timeout in the license check when vCenter is inaccessible for longer than 5 minutes

Resolution

This issue is resolved in the Bitfusion 4.5 release

Workaround:
Prior to 4.5.0, the workaround for this is to SSH into each Bitfusion Server node using the customer account and restart the bitfusion service:

# ssh customer@$bitfusion_node_ip

# sudo systemctl restart bitfusion

Additional Information

Impact/Risks:
Bitfusion servers may not serve GPU functionality to Bitfusion Clients until the vCenter accessibility is restored and license check is confirmed.