vCenter Server Appliance 6.0 の /storage/log ディレクトリがいっぱいになる
search cancel

vCenter Server Appliance 6.0 の /storage/log ディレクトリがいっぱいになる

book

Article ID: 319328

calendar_today

Updated On: 12-26-2024

Products

VMware vCenter Server

Issue/Introduction

vCenter Server Appliance の /storage/log ディレクトリがいっぱいになる問題を回避するには、log4j.properties ファイルで、最大バックアップ サイズと最大バックアップ インデックスを減らします。

Symptoms:
免責事項:これは英文の記事「/storage/log partition full due to SSO log files are not compressed in vCenter Server Appliance (341135)」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。

vCenter Server Appliance または Platform Controller Server Appliance 6.0 で、/storage/log ディレクトリの使用率が高い。
 
:その他の症状およびログ エントリについては、「追加情報」セクションを参照してください。


Environment

VMware vCenter Server Appliance 6.5.x
VMware vCenter Server Appliance 6.0.x

Cause

この問題は、/storage/log ディレクトリで SSO ログ ファイルが増大することが原因で発生します。ログ ローテーション中に古いログ ファイルは圧縮されず、/storage/log ディレクトリに複数の大きいファイルが残ります。

Resolution

この問題は、Broadcom Support Portal で入手可能なVMware vCenter Server 6.0 Update 3で解決されています。
この問題は、6.5 Update 1でも解決されており、Broadcom Support Portal で入手可能です。

Workaround:
問題を解決/回避するためのビデオチュートリアル:
 この問題を回避するには、log4j.properties ファイルで最大バックアップ サイズと最大バックアップ インデックスを減らします。 注:外部のPlatform Service Controller(PSC)環境では、代わりにPlatform Service Controllerにログインします。 注:この回避策は、6.0バージョンのみに適用されます。
log4j.properties ファイルで最大バックアップ サイズとインデックスを減らす手順:
  1. vCenter Server Appliance のコンソールに root ユーザーとしてログインします。
  2. 次のコマンドを実行して、Bash シェルへのアクセスを有効にします。

    shell.set --enabled true
     
  3. shell」と入力し、Enter キーを押します。
  4. 次のディレクトリに移動します。

    cd /usr/lib/vmware-sso/vmware-sts/webapps/sts/WEB-INF/classes/
     
  5. 次のコマンドを実行して、log4j.properties ファイルをバックアップします。

    cp log4j.properties log4j.properties.bak
     
  6. テキスト エディタで log4j.properties ファイルを開きます。
     
  7. 次のエントリの下にある、log4j.appender.LOGFILE.MaxFileSize および log4j.appender.LOGFILE.MaxBackupIndex パラメータを見つけます。

    log4j.appender.LOGFILE.File=${catalina.base}/logs/vmware-identity-sts.log
     
  8. パラメータの値をそれぞれ、50 および 5 に変更します。:

    例:

    log4j.appender.LOGFILE.MaxFileSize=50MB
    log4j.appender.LOGFILE.MaxBackupIndex=5


    注:デフォルト値は、MaxFileSize=100MB MaxBackupIndex=10 です。
     
  9. 次のエントリの下にある、log4j.appender.PERFLOG.MaxBackupIndex パラメータを見つけます。

    log4j.appender.PERFLOG.File=${catalina.base}/logs/vmware-identity-sts-perf.log
     
  10. パラメータの値を 3 に変更します。

    例:

    log4j.appender.PERFLOG.MaxBackupIndex=3

    注:デフォルト値は、MaxBackupIndex=10 です。
     
  11. 次に移動します。

    cd /storage/log/vmware/sso/
     
  12. 次のコマンドを実行して、古い localhost_access_logvmware-identity-sts、および vmware-identity-sts-perf ログ ファイルを削除します。

    rm localhost_access_log.*
    rm vmware-identity-sts.*
    rm vmware-identity-sts-perf.*

     
  13. 次のコマンドを実行して、STS サービスを再起動します。

    service vmware-stsd restart

    注:STSサービスを再起動することで新しいログファイルが/storage/logディレクトリに作成されます。
    注:削除を望まないVCSAから取得したログバンドルを削除しないように注意してください。


Additional Information

さらに次の症状が発生します。
  • /storage/log/vmware/sso ディレクトリで du -sh コマンドを実行すると、数 GB の領域が使用されていることがわかる。
  • vSphere Web Client で、次のアラートが表示される。
     
    • Available storage for logs /storage/log reached warning threshold - less then 30 % available space
    • Available storage for logs/storage/log reached critical threshold - less then 15 % available space
  • /dev/mapper/log_vg-log がいっぱいになる症状も発生します。
この記事の更新時にアラートを受信する場合は、[Actions] ボックスで、[Subscribe to Document] をクリックしてください。

vCenter Server Appliance のディスクスペースの更なる問題:vCenter Server Appliance Maintenance Series: Troubleshooting disk space related issues 

/storage/log partition full due to SSO log files are not compressed in vCenter Server Appliance (341135)